@Scruffynerf,
Sure, you can get a small bit of performance with a constant. You can also do that in the pattern with a var. Vars, literals, and constants have near the same performance. e.g.
var HALF_PI = PI/2
If I were to add half-PI to the constants, what should it be called? HALF_PI, PI_2, PI1_2? The naming convention I borrowed sort of uses _ in place of division, e.g. PI3_4
is PI * 3 / 4. I added PI2 because I used it a lot, when I really wanted 1 Tau.