Browser support issues

Has anyone made it known of various browser support issues of late?
I have a windows 10 and Linux and all my browsers started having difficulty’s rendering the page the animation just spins but never logs into the device.
I have updated the firmware and reset it multiple times but no good results. any ideas as what might be the problem I have tried chrome, firefox, edge:[ and IE11 all have the same problems, wireless router TP link.
Maybe you can point me in a direction to figure out what changed.
Thanks in advance

Hi Scott,
There’s a few things we can try.

Does it work on some browsers? The first thing I’d want to do is see if its browser/network related, or something on the device itself.

How did you go about updating firmware? Are you uploading manually? Which version is it running or uploading to it?

Can you open up a browser console and see if any messages/errors are shown when reloading the page?

Try putting it in AP mode, can you load the page then?

Sometimes this is caused by network issues, and restarting the router can help. If putting it in AP mode fixes it, I would lean in this direction.

It may have a corrupted index page, which can be fixed by updating. This should show up in the browser console too.

Thanks Ben.
I will try the AP mode. In answer to the question, it does this on all browsers, I have a dedicated network that it is on. I did update to the latest firmware version in hopes that would resolve the issue but no such luck.
It will at times load after awhile on firefox IE11 will never go beyond the animation splash screen.
Just to clarify it was all working fine and then one morning started having these issues.
I’ll try the AP mode to see if I get similar results and circle back.

Thank You for the help.
Scott Frazier

I have noticed at times (unsure about latest firmware, haven’t used it enough yet) that it’ll stall on the main loading spinning cube, in one browser, but I can open it another browser onthe same computers and it works. It seems inconsistent, though, and I was thinking it was a cookie issue or some other “out of sync” issue. Definitely v3 has been a bit more temperamental overall. Still some bugs to shake loose, likely.

Ben, Scruffy
Puting the device into AP mode seems to made the issue resolve it’s self. The issued ip address by the router is and I don’t see a way to static it on another ip address.

1 Like

This sounds similar to a previous issue where restarting the router fixed things. Worth a try!

Quick aside, how did you go about updating if you couldn’t load the main page? Are you running the new recovery page in v3.18? Does the recovery page load and show status?

Can you try with a browsers dev console up? Any error messages?

At times it would finally load, so the last time it fully populated I figured to try the firmware flash just in case it was the issue causing the problem.

Hi @scottf ,
To clarify, is it now working fine connected to your network (Client, not AP mode)?

If I take it back to the network it always defaults to the same ip address. If there was a method of changing it, I might get it to resolve.

I have defaulted my router with no sucess.
I’ll keep messing with it.

Scott Frazier

Usually in the router config, there is a listing of assigned IPs and the ability to release/delete them. Often you can also assign a particular IP.

Depends on the router of course. Might be in advanced settings.

Hi @scottf ,
This sounds like it might be a signal level issue. If it works sometimes, and you can start loading the page, I don’t think its an IP address issue.

When you put Pixelblaze in AP mode, the biggest thing that changes is that your client device is connecting directly to PB. WiFi packets don’t have to bounce to your router and back.

I’d check that there isn’t anything new that is metal/metalic near the PB antenna, or new things around/near it that might have changed the reception. Can you try moving things closer to the router, see if that helps? You can see signal level in a WiFi scan on the WiFi settings page as a small blue icon. Ideally it would be a rectangle that is taller than wide. If all else fails, WiFi repeaters can help extent the signal and improve connectivity.

I have tried pretty much all avenues of trouble shooting
the device is less than 1 meter from the wifi antenna hanging on the wall. I did a router reset to see if that fixed any thing, no such luck. It does work fine in AP mode just as it did a month ago. I don’t know what changed but it effected all my Pc’s, even my linux machine.

Scott Frazier