Drops off wifi / can't connect - reboot works

The PB started acting weird & stopped responding. I rebooted it and it seems much happier, and now lets me save the pattern.

@UnstoppableDrew, just out of curiousity, what browser are you using to work with Pixelblaze?

Just a quick heads-up to @Wizard – I’m seeing this sort of intermittent misbehavior again on my PB3 (with the latest firmware) with recent Firefox builds. I’ve had it refuse to generate the preview, drop frame rate to near zero and become unresponsive for several seconds while saving, lock up completely, and in one instance, completely eat a pattern I was working on. It seems to happen most often when running patterns that are computationally intensive.

I’ll see if I can get better debug information for you from the browser, but I was also kind of wondering: I have a lot of large patterns on my Pixelblazes. Could I have just filled up the file system to the point where it becomes unhappy?

I’m using Chrome. Mine definitely isn’t out of space, I’m only just getting started so it’s got the built-in set and 2 or 3 tiny ones I added.

Possibly. I have seen the filesystem become very slow when things get fullish. The 3.17 version I’m releasing soon shows free space on the patterns page, plus tons of other goodies.

@UnstoppableDrew ,
It may not hurt to remove some unnecessary patterns.

The size of the pattern is often dominated by the preview, which is a JPG and compression rates are lower for complex patterns. The source is compressed, and usually 50% or so of the text size.

I have also noticed some of my PBs dropping off the network. Its fairly rare, much better than early 3.x days, but not where I’d like it. A lot of this comes from underlying libraries / OS, which makes things harder to debug/fix.

Ya’ll up for beta testing 3.17? I’m curious what free space you both have.

1 Like

Similar here; I’ve had the occasional pattern that would make a PB unresponsive, and a couple of times my PBs have stopped responding on the network after a week or so of use. They were still running patterns, but they wouldn’t respond to HTTP requests (even after rebooting) until after they’d been powered off for a few hours.

I’m game. Another thing that might be useful is a reboot button in the settings page. I just noticed a stuck pixel in my last panel. Just changing patterns didn’t fix it and I was wondering if restarting the PB would kick it, or if it needed a power cycle.

So a stuck pixel is usually that something turned it on, but nothing is turning it off. Remember ws2812s persist, doing whatever they were last told to do. It’s not like they all go dark and reset and you have to light them up continually.

If you light up pixel #63, and then begin to do stuff with pixels #0 thru #32, #63 will just continue to stay lit until you send a command that reaches it and changes it.

Right, but I tried switching to the Color Hues pattern and it’s still stuck. I also tried telling it I had both fewer and more leds than I actually do, but that also didn’t do anything.

Bugger, I think it crapped out entirely. I power cycled the whole thing and now I’m only getting 3 out of 4 in the top vertex of the last triangle (which is the entry point) and none in the other two.

Sigh. It’s kind of a pain in the ass getting it on & off the wall, I think I’m going to route some keyhole slots in the plywood back so it hangs, rather than the current method of screwing through it into the studs.

Edit: Having just typed that, I looked up and they’re all working again. It just needed a nap or something. However, I suspect that’s a warning sign that that one is not long for this world. If I have reason to take it down I’ll replace that segment, toss the flaky one and throw the other 3 in the spares drawer.

1 Like

Yeah, a pixel stuck on, or ones that don’t light up after a particular one is usually a sign of a bad connection, including potentially internally. Remember, each pixel acts as a repeater, using the 100 bottles of beer method: take one down/off and pass the rest along. So any one pixel can prevent others past it from working correctly.

@wizard, I’m up for beta testing too. I probably really am abusing the file system. I have patterns with lots of static time series data, bitmaps and bits of video for POV stuff, and other off-the-beaten-path experimental things.


I have seen ws2811 get stuck that needed a power cycle to come back to life. However, more often than not flakey ws2812 LEDs are a sign they were manufactured poorly or otherwise exposed to solder temperatures without dehumidification, and aren’t long for this world.