Expander v1.2 introduces random flashing

I have an older (v1.2) output expander that I’m trying to work into a build. So far I’ve got 137 WS2812 working fine with a v3 Pixelblaze powered (for now) by USB with about 1m of 20 gauge wires between the Pixelblaze and first LED.

When I introduce the output expander into the same circuit with my lights on channel 0 and reconfigured in Pixelblaze settings, the selected patterns still work but random lights now briefly flash white, around 50 flashes/second. If I turn the brightness all the way down, the pattern is no longer visible but the flashing continues at full brightness. The lights are getting 4.96V and drawing about 0.3A.

I feel like I also once experienced this with some WS2812 on the older output expander (this is the one with the chip mounted like a rectangle relative to the expander board, not diamond, right?) It went away with the newer output expander (and never happens when I use SK9822).

Out of curiosity does the flashing go away if you shorten the distance to first pixel? Assuming that’s easy enough to do.

I’m also curious if shortening the data wire length helps!

What is happening is that the zero bit pulse is being interpreted as a one, but only occasionally at random. My guess is that the timing is close to the threshold between a zero and one, and random noise occasionally pushes it to a one. There’s a little bit of jitter/noise in the timing generating the signals, and you might be getting electromagnetic interference, I wouldn’t be surprised if your roughly 50 flashes a second lined up with the mains cycle in your house. It could also be fluctuations in the voltage at the LEDs, or any combination of these things.

Without knowing the cause, we can still shoot in the dark a bit with a hack.

  • Try adding some bulk capacitance for power at your LEDs.
  • If you pull down the output, the output voltage will lower, and that might be enough to reduce the resulting size of the 0 pulses. Too low and the pulses won’t ever be recognized. You could wire up a potentiometer (between data and GND) and try to dial it in.
  • If the LEDs work close to the expander, move the expander to the LEDs! The data to the expander has CRC checks and can survive longer runs without causing glitches than WS2812 data can.
  • Try using an LED close to the output to regenerate the signal (if the LED close to the output gets good data, it will generate compatible output pulses for the far LEDs)
  • Try a V3 expander

Shortening the distance isn’t really an option for this project and I’m tight on time so I didn’t test that. I tried adding bulk power capacitance near the LEDs with no effect. I have a V3 expander on the way but I’m just going to move forward daisy-chaining the segments without an expander for now as I’m bringing this project to Critical NW in two days. :smiley:

I really appreciate the prompt and thorough support. It’s a big part of the reason I recommend Pixelblaze to my friends.

Come see what I’m building at Burning Man! I’m camped with Tautology at 8:45 and F. It’s an interactive fairy ring and will be installed in camp.

2 Likes

Hello all,

I’m seeing this same issue. I have noise showing up on 2 of 3 ports on the output expander. It doesn’t seem to matter which ports I use. I had it on a regular V3 board and it affected appx. 30 pixels. Then I was using 2 ports but only had noise on 1 port. On the back it says it’s a v2.0 02019.
I have it paired up with a new V3 Pico board that I just received a few days ago.
I’ve tried a different power supply thinking maybe it’s noise but that didn’t help. I’m getting white flashes on the beginning of the string down to around 6 pixels. Again, I only see it on 2 of 3 ports on the Pico board connected to the expander. My data line is only 3-4”.

Don.

Psygantic,

Hopefully I’ll stop by in my PVC Pedal car with Pixel Blaze controlled lighting. I’m running about 700 SK9822 pixels inside of 3/4” white pex tubing. It looks pretty cool.
I may end up taking out the expander board if we can’t work out the issues and just run 3 strings in parallel.
Hopefully will figure it out soon.