Failed upgrade from 2.22


I just tried to update from 2.22 (if I recall correctly) using online firmware upgrade button from the settings page, the device appeared to reboot as the light sequence changed and now I can no longer access the admin as binary is returned.

⇒ curl --output -

??k^??v?Ʋ0??O?(+'VLB?UZ???ىgŎO?${??|{?H" n??p?<ļ??y?y????%%3?7?l?쮮??????U????w?????W??Z?W=???<^/.???&?qr?Q<[?U̖?L?ˣ]5?ɌeUm??v????_??|?}^?6q?M??(??*]C??_]??"Uʭ?Uzyt??7?b[)?7YR-/??:??]?d???[??<??Q4y?~l???\?ٮ


Hello @mmaton,
The curl output is expected. The html is gzip encoded, and since the supported browsers support that, there’s no plain-text version available. If you save it to a file and ungzip it, you should get a big html page.

It does look like PB is getting online, and is accessible. What do you get when you load it in a browser?

The firmware update process hashes the data, and then checks against a cryptographic signature, so it’s not likely to be corrupted in transit. Flash corruption is possible, but uncommon. Running the update again might clear that up.

See if the /update page loads.

Based on your post above, thats:

And you can try feeding it the Signed Transfer Firmware Update file manually:
v2.23.stfu (736.0 KB)

Thank you @wizard Ben :slight_smile: The update page worked from my browser and I was able to upgrade to the attached version!

Now the device works as expected when navigating to It’s IP

Interestingly the websocket was working perfectly - I could set the brightness no problem

Thanks again