Having issues with WS2812

I’m trying to hook up this WS2812…

With the PB controller. And I’ve followed the instructions

This image shows the wiring

I’ve tried it with and without the power, with and without powering the PB through the micro-usb, but all I’m getting is a few pixels lighting up or just the first pixel dimly. I’ve also changed the strip type to WS2812 in the config.

Any ideas?

I’m not 100% sure, but it looks like you may have the GND and DATA reversed. GND is normally the blue wire, and DATA the green wire. To verify, follow the wires back to the strip and see what is printed near each of the three pad connections.

Hmm, I thought I tried that, but they did come to life when I switched the wires. But, for some reason it’s not outputting the right color. For instance, when I use rgb(1,0,0) I get this.

Since I’m powering the PB separately there is only two wires to even work with. I’m a little baffled.

Happy Xmas eve btw :slight_smile:

Hi @mad ,
Those are RGBW, with 4 elements instead of 3 so you need to select one of the RGBW options (try GRBW). Otherwise the elements get all offset and the colors won’t work right.

Perfect! Thank you Wizard!