How do I wire external power supply?


Just getting my toe into LED lightning. I’m not a complete newb to electrical wiring, but I cannot find any kind of picture or diagram to help explain how to wire my Pixelblaze to an external power supply. I was able to connect the PB to my wifi thru micro USB, but I bought a BFT-lightning 5-meter stand, so only the first foot lights up (as I expected.) What’s my next step?

Thanks in advance.

1 Like

Wire those two to the power supply (they are already connected to same wires on the PB, which you have connected).

Don’t plug into USB.

And you’re good.


Ok, It wasn’t powering up before, but it is now. Might have had a loose connection.

Now, under Micro USB, the whole string lit up, but rapidly lost brightness. Now, it’s only powering up the lights about 12 inches. :frowning:

1 Like

Some common causes of loose connections are solder joint issues and not stripping enough of the wire for the screw terminal. I’d check both of those. You’ll also need to set up the LED type in settings, and configure the number of pixels. Any of those kinds of issues can cause the LEDs to not work correctly.

The solder should flow smoothly to all of the metal bits, like it’s wicking to it. Here’s a great guide on that, with photos!


Ok, settings was the issue, and apparently the RGB color order needs to be adjusted as well. Other than that, it’s working peachy-keen! Thanks! :smiley:


I have a similar question since I’m a newbie.
I got the Pixel Blaze and 4m RGBW LEDS: 4 meter spool of 60/m [SK6812]

I haven’t even soldered the connector or tried to power it up, but as I gather now, I won’t be able to power more than about a half a meter of the spool from the micro USB(?)

So I’ll need and external 5V power supply that can deliver 10A+, yes?
What external power supply do you recommend for this 4m spool?

Hi Craig!

I like these ~$30 15A supplies for my 4m 60/m strips. Because they’re wall (115VAC) to barrel, they work out of the box with the strips Wizard sells on Tindie, and you have the peace of mind that you can mess up your code and never overpower it for this strip size.

ALITOVE 5V 15A AC to DC Power Supply Adapter Transformer Converter 5.5x2.1mm Plug 100V-240V AC Input for WS2811 2801 WS2812B LED Strip Pixel Light

There are cheaper 5V options, especially if you don’t need Prime shipping, will never accidentally throw full white at them (then only 5A!) and are willing to solder. It’s a calculation with the value of your time.

Hi @Craig,
You can, but not at full brightness across the whole strip. The LEDs consume current proportionally to their brightness. It also depends on the color, but you are in luck with RGBW.

I’d follow Jeff’s advice for the best experience, giving them enough power will let you use the full range and get the most out of your LEDs.

Keep reading for more details on what is possible with just a USB power supply.

Since you have RGBW I recommend using the RGBW/GRBW not the RGB-W or GRB-W color setting. The “-W” will avoid using the white element and instead mix RGB which uses more current.

You can figure about 0.02A per pixel at 100% brightness. On the other end of the constraint is a USB power supply. The USB connector is rated at 1.8A, and not many USB power supplies are rated above 2A, so I’ll use the 1.8A figure for calculations. Some USB power supplies/chargers aren’t rated for that much, so its best to read the fine print on them to get the rating.

With 240 LEDs to power, if you split the 1.8A up evenly, you will get 0.0075A per LED, or 7.5MA. This is 37.5% of full power. If you set your “Limit Brightness” setting to 37.5 you should be OK!

Thanks Jeff and Ben.

I just ordered this 15A power supply since I can get it on Dec 23rd:
JOVNO 5V 15A Power Supply Adapter Converter

The one Jeff recommended would arrive on the 27th, which is that much past the holiday lighting peak :slight_smile:
Not that I absolutely need it before Christmas, but would be nice to get started that much earlier on my little project.
Nothing specific in mind but it looks so easy to program, thought it’d be cool to do something Christmas-ie.
Eventually would like to do some music visualization.
And I dug out my soldering iron from the garage which I’ll use to solder the connector later today.
Just wondering, the wire connector doesn’t come soldered on to give users move flexibility in case that don’t want the connector on it for whatever they’re using it for? Or can break off easily in shipping? Both?
Then I’ll start playing with it using the USB adapter.
I didn’t know there was a brightness limiting feature, so that’s pretty neat.

Thanks again.

Well, I soldered the connector and powered it up from USB with 240 LEDs attached.

I was able to connect via AP and get into the PixelBright settings.

Part of the reel was lighting and so I went into the setting to turn down the brightness and set for the WS2812 type.
Wasn’t fully responding. I set brightness limit to 20-25% and communication to the slowest. It did light up the whole reel with white and amber colors for a period. But then it stop responding so I unplugged the USB. I noticed the plug was hot so ya, not good.
Since then I’ve unplugged the LED reel.
However, connection to the PixelBlaze menu is intermittent.
Have been reading through some of the troubleshooting post in this forum.
I do see it appears to be power cycling once in a while based on seeing the status lights flash.
Sometimes it will cycle about every 5 minutes.
I checked the supply and its 5.08V.
The blue and amber lights of the PB are on solid but after it flashes, I have to reset and go through the AP setup steps again.
I did go in to change to LED type to “No LEDs” and am keeping the reel disconnected until my 15A supply comes in a couple days.
I am also using a USB cable that has a label “power only cable”. I figure for this, its OK(?)

I’ll try again tomorrow.

update: tried a different USB supply and USB cable but PB is still resetting. Sometimes stays on solid for a few minutes. Sometimes just ~15 seconds.
Tried connecting from my iphone and windows laptop but they both seem to loose connection after a short period.
It is on my desk with several wifi enabled devices. Don’t know if that may have anything to do with it.

Try checking your soldered connections. I had similar issues and had to redo mine.

[Edit] Sorry, noticed you’re using USB power. That said, my USB connector is a little funky, and any movement disconnected it.

Try USB power with just Pixelblaze, no LEDs. Does it remain online?

It definitely sounds like you are drawing more over USB than intended. Nothing should be hot, especially the connectors.

Many USB ports and power supplies will show down if too much power is drawn.

Just to clarify, the resetting has been happening with the LED reel disconnected. It does not remain online.
And that was happening with different USB adapters and cables.
I am waiting for the 15A supply to arrive (should be today), so I haven’t fiddled with the Pixelblaze since a couple nights ago.
So I thought I read in another thread that resetting/disconnecting could be due to other WiFi devices near by, is that right?
I wonder if a glitch on the 5V supply could be causing the reset. I haven’t studied the schematic (its published?), but does the 5V supply have a bypass capacitor?

See if the USB connector on the PB allows the inserted USB plug to wiggle. It did on mine, and I would lose power unless the plug was pulled to one side. I’ve had no problems using an external power supply.

So I got the 15A power supply about 40 minutes ago and its having similar problems.

The whole reel of LEDs light up white, and PixelBlaze’s two LEDs light up after I config AP. But after I setup the AP mode, it gets flaky. I select that Wifi network (which I’ve named and setup a password). I point the browser to and it has a hard time connecting. Sometimes I get just gets stuck at the “Loading…” spinning cube. Sometimes it goes all the way through and I get to the menus to take control of the lights. But before I can try anything, it disconnects.

When I try to reconnect with my web browser (tried w/ Windows and iPhone), it won’t, and I have to go though all the steps again by holding down the reset button for 5 seconds.

And when its powered up, I still see the Pixelblaze LEDs blink every few minutes, which I assume is a reset.

Before I hold down the reset button for 5 seconds, the Pixelblaze’s AP WiFi network still appears to be available with the name I gave it. But all attempts to reconnect fail.

So I haven’t been able to control the LEDs at all.

Hi @Craig,
Sounds like something is wrong with your Pixelblaze. It shouldn’t reset like that (blink LEDs), and you’ve tried different power supplies and isolated things. I’ll get you a replacement. Sorry for the trouble this bad unit has caused!

Older versions could have issues with certain WiFi network gear in AP mode, but figuring out if that is the case with just one PB means trying to run it somewhere else, away from your house.

I’ll get that send out ASAP, though with the holidays USPS is a bit overloaded.

OK, thanks.
So the PB LEDs stay on solid most of the time. But after a few minutes, it blinks, which I think is resetting and after that I can’t seem to connect.
Ya, getting away from other WiFi networks would be a tricky in my neighborhood.
Thanks for sending me a new one. It seems like a really cool LED controller so I’m looking forward to trying/creating patterns.
I can send you the one I have now after I get the replacement, if you want.
I will try it again and see what firmware version it is. But I just got the PB a week ago so would think its pretty recent.

EDIT Sorry I see that you tried with the leds disconnected so my idea below is pointless.

The other day I was playing with some APA102/HD107s and displaying white. I discovered that if I set the brightness too high it caused the voltage to drop and the PB and usb port to reset. I had to reboot the computer. Have you tried lowering the brightness to say 30% max and then seeing if you still have the issue… Maybe even try 20% max brightness just to see if that helps then we can go from there.

The trouble is I can’t stay connected long enough to turn down the brightness or anything else, with or without LEDs connected.
I think one time I was able to change the LED type and that seemed to do something, but that was about it.
But a replacement PB is on the way :slight_smile: