I get “ready to connect when network quality improves” No setup page is displayed

When you power it on and it is in setup mode, it should BLINK then flash 3 times quickly, then go to solid dim. It should not flash/blink further.

Can you take a video of the LED when you first apply power?

No need for video, that is exactly what it does.

The way I read it, two different behaviors have been described.

Does not mean the same thing to me as:

If the start up flash+blinking sequence is repeating, then the PB is restarting and won’t be able to maintain a connection. @Schangele has posted a video above that demonstrates this restart cycle/loop repeating several times.

@Schangele thank you for that, I will follow up via direct message.

Just received my new PB 3.4 from Crowd Supply today.
Plugged it into USB cable and it came up like a champ.
No connection problems here. PB goes to WiFi Settings screen
right away. Retried the old PB3.4 and no WiFi Settings screen is displayed.
I believe I have a defective board. Would you like me to send this board to
you for your post-mortem review.

Now stuck on Loading screen!!! Seems I can’t catch a break.
Been thru forget network and re setup AP Mode with no luck.
Nice pretty 3D rotating cube that goes on forever.

Hi @Garypixel ,
Sorry to hear another one is giving you problems. What OS(es) and browser(s) have you used? Is that with anything connected, or just powered over USB?

Yeah, if you want to ship the other one back I can test it and replace it for you, or send you a V2 if there is some kind of compatibility issue with V3 and your systems.

What OS(es) and browser(s) have you used? Is that with anything connected, or just powered over USB?
I am using Google Crome and the phone is a Samsung Note 8 running Android 9. PB3.4 is powered with USB cable with nothing else connected. Please provide address to send PB3.4/w sound board for your testing. Replacement board would be welcome (thank you) V2 please.

Under the Wi-Fi preferences I had to turn off intelligently select the best Wi-Fi network. Also under advanced features tab I had to turn off automatically connect to Wi-Fi network.