I get “ready to connect when network quality improves” No setup page is displayed

Pixelblaze V3.4 when first powered up flashes once then 3 times then goes to dim led.
Patteren continues to repeat. I can see Pixelblaze_28A18D on phones wifi network.
I get “ready to connect when network quality improves”. and then "internet may not be available.
No setup page is displayed. I have a Pixelblaze V2 running and have no problems It up and communicating just fine. Could I have a bad Pixelblaze board??? I have the sound board
connected to the Pixelblaze as well. Help me Wizard you my only hope.

Hi Gary!

Those error messages sound specific to the Android mobile OS. It sounds like you’re trying to connect to the Access Point built-in to pixelblaze to do the initial configuration, such as entering your home wireless netwrok’s info so Pixelblaze can operate in client mode instead of AP mode. You might know this from your PBv2, but Client mode is important so we can easilyupgrade the firmware version. “v3.4” is the hardware version printed on the PCB, but the firmware version is displayed in the interface header, and v3.20 is the current latest as of November, 2021.

Just want to confirm a few things.

  1. After connecting to the Pixelblaze_28A18D network, are you trying to go to

  2. Do you have a laptop you can try this from?

No laptop just a gaming PC. When trying to connect to wifi network the Andriod phone does try to go
to but just times out. I have no issues with my PBv2, it works great. Makes me suspect
the board itself. Could file corruption be at play here.

“Does it eventually stop repeating, and get to a consistent state?” Yes
It will go to dim led state and stay there. I have the sound attached if that makes any diff.
PB is being powered with USB form computer. Thanks for helping out a young Jedi.

What signal strength do you see in the network scan for the “Pixelblaze_28A18D” listing? If that is showing up with a weak signal moving it around, making sure the antenna is clear of anything, and that sort of thing might be the cause.

Many phones switch between wifi and cell data for the best internet connection, and of course a Pixelblaze in AP or Setup mode will not provide any internet. Some phones are configured to ignore that network completely - even local addresses like the address.

You can try disabling automatic network switching, perhaps shown as “Smart Network” or disable cell data temporarily to get around the problem.

You can also try the “forget this network” and reconnect. This can help if your phone has incorrectly remembered to not connect/use that network.

Depending on the firmware version of your Pixelblaze, you may be hitting a bug that can cause trouble accessing the setup page directly via IP address during setup mode. Normally this pops up automatically and may ask you to “sign in” to the network. If you can connect to it’s WiFi network, but don’t get any prompts, and the setup page isn’t loading by IP address alone, try this URL (while still connected):

1 Like

NO luck. I can connect to my PBv2 without fail. When I connect to PBv2 my phone reports a screen
with "network speed "displayed 65mbps
“security” none
“ip address”
“manage router” Here is where I find Saved Patterns / Run sequence and I have full control.

Thats in the network detail screen, right? Can you get that for the Pixelblaze_28A18D at all?

What was the WiFi signal strength of the Pixelblaze_28A18D network?

What do you see when you switch to the Pixelblaze_28A18D network?

Did you try forgetting the Pixelblaze_28A18D network?

Are you getting any notifications when you first connect to it?

Does it stay connected, or does it kick you off?

Sorry for all the questions, its hard to follow what steps you are taking and where exactly you are getting stuck.

I can get to “network detail screen” when connected to Pixelblaze_28A18D.
I get the same “network detail screen” minus the “Manage router”
WiFi signal strength is strong.tried

Forgetting the Pixelblaze_28A18D network has the same outcome.
Get same quality and internet messages.
I do stay connected

Hi @Garypixel ,
While connected to Pixelblaze_28A18D, with cell data off, can you load this page?

Hello, I have the same problem. I had a connection to the wifi on the first connect, ran the update and now I can’t get a connection. Wifi is sometimes there and then gone again. When I try to connect I lose it right away. It works neither with android mobile nor with my laptop.
Oh and hello from germany and sorry for my english i use a translator

While connected to Pixelblaze_28A18D, with cell data off, can you load this page?

Tried this and get

no webpage was found for web address

@Garypixel ,
Can you access the recovery or update page?

Try this first:

If that fails try this:

If you can’t load either page, then I think it might be network related, like either you aren’t staying connected to PB’s network or aren’t getting an IP address.

When you look at the network detail for your V2, you saw

“ip address”

Do you get a similar 192.168.4.X IP address with this network?

@Schangele ,

Try it while keeping an eye on your Pixelblaze, what is the orange LED doing?

When connected to V2 thru the “manage router” on network detail page I get
the “Saved Patterns Run sequence” @
I full control of V2 pixelblaze with no dropouts and steady bright led.
Very perplexing V2 works with out fail while v3.4 does not. If there was a network
problem why does V2 work so well.

it flashes once then 3 times then goes to dim led

@Garypixel ,
I’m not familiar with the “manage router” button, but I suspect it just takes you to a browser pointed at default gateway IP address assigned when you connect.

Your v2 seems to be working for you, and I’m trying to help troubleshoot the problem on your V3. Once I have an idea whats going on can suggest possible fixes. I only mention the V2 because it gives you a working system to compare with.

When you connect to a Pixelblaze’s WiFi network, it will use DHCP (dynamic host configuration protocol) to get information about the network. DHCP assigns an IP address, default gateway, DNS servers, etc. Some of this should be visible on that network detail screen. For example, you could see that when you connected to V2 you got an IP address of “” which is an important detail.

If you can, please upload screen shots of that network detail screen for both V2 and V3.

Did you try any of the suggested URLs in the previous post? If so, please provide as much detail as possible, screen shots can help here too.

i have another pxelblaze v3 board that works fine

My PB V3 does the same thing, it will go thru the 1and 3 flashes several time and settles
with the led on constant and dim. Glad to see you have a PB that works.

When V2 is connected it is connected to“”
When V3 is connected it is connected to “”

Thank you devoting so many “Brain Cycles” ( an Elon Musk thing) to the problem.
I will order another PB 3.X (what ever is offered on Crowd Supply)
I could use another PB for other projects and gifts. Let see if the next PB works.
Thanks again for all your help.