Just blinks white. Can't reset to Wifi Setup mode

I’ve got a v3.12 that suddenly stopped following its pattern and now all LEDs just blink white every 3 seconds or so.

I’ve tried holding down the button for 5 seconds while powered many times, but it doesn’t seem to do anything.

At first I could see it at discover.electromage but it would not load. After a hard reset now I cannot find it at discover.electromage at all.

I have several others on the same network that work fine.

Any help?

Hey @bunbunfriedrice - sorry to hear about this.

The blinking white sounds suspiciously like it’s browning out because that initial blink of white is drawing too much current, which in-turn reboots the board after the voltage sinks.

The simplest place to start would be to have you disconnect the LEDs and power the Pixelblaze controller board alone. If the LEDs were providing power to the controller and you have a Pixelblaze standard, you can provide 5V via the micro USB connector after disconnecting your LEDs. If my theory is right, this will let you discover it, login, and turn down the global brightness; after that you can consider whether you have enough oomph in your power supply and power injection points.

It might be something else, but this is so fast to check – this is where we should start.

Let us know how it goes.

1 Like

@jeff Thanks for the quick reply!

The pattern does not have any blinks of white.

It did seem to break when the date changed, and I had pre-programmed a color change for the 4th of July. Though, that same pattern with the date change had no issues last year.

I can try disconnecting the LEDs, but it might take some time though as the wiring is unfortunately not very accessible. Are there other options to try in the meantime that don’t require disconnecting?

Hmm, well, if you can visually see the small status LED on the board, it’s worth trying to verify that it’s indeed blinking off. This means reboot or brownout. A brief video here may help. For example, here’s a Pixelblaze experiencing a repeated brownout:

We could also assess the likelihood of a voltage drop issue by:

  1. Having you use a relatively fast-updating volt meter to watch the voltage across the main 5V screw terminals. If you see it dip below 3.7V this is likely the problem.
  2. How many LEDs are connected, and what model power supply did you use? Is the power supply connected near the Pixelblaze?

Yes, I am able to view the orange status LED on the board and reach the reset button.

When powered on with the repeated white blinking, there are no blinks or anything on the orange status LED. (Nothing when pressing/holding the button either.) So perhaps it’s not browning out?

Right when powering on the device, I see one orange blink, a brief pause, then three repeated orange blinks.

Re: #1. I don’t have a voltmeter on me but will try this soon–thank you!

Re: #2: It has ~100 LEDs. Powered by XinSPower model A241-0504000U, input 100-240 V, 50/60 Hz 0.8 A, output 5 V 4000 mA. Yes, the power supply is connected directly from the Pixelblaze to the AC outlet.

OK, this may or may not be a brownout.

The three-blink pattern is what you see when the WiFi has been reset. If you wait 20 seconds after powering up, can you see a WiFi network being created (using your phone or a laptop) called Pixelblaze_XXXXXX?

That power supply is on the margin - It’s big enough to support 60-80 typical LEDs at full white. If you recover this setup, be sure to set the global brightness to 70% or less.

Interesting that I’m seeing the WiFi reset pattern. No, I don’t see a Pixelblaze_XXXXXX network pop up. (I also cannot connect to which I read should be the default in setup mode.)

The pattern should be supporting fairly low brightness overall and nothing full white, but perhaps it’s just having trouble getting started. And yes, I’ll put the global limit to 70% once I recover this.

Any suggestions/link for a better power supply?

Also, if it matters, I (fortunately) was able to copy/paste the pattern code offline before the issue persisted. So if there’s some other way to hard reset the board then I am not concerned about losing the code. I’d just have to do the other setup like recount pixels and other settings.

I really like the Alitove 5V ones - they’ve got a decent enclosure and ship with a barell jack, which works out of the box with the strips that include a male barrel for power injection (such as the ones we sell in the shop).

We might be approaching the point where disconnecting the LEDs will be most useful in eliminating the power draw thesis. I think you have access to the board because you could push and hold the button to reset wifi; did you connect the LEDs using the screw terminals - or is it much harder to disconnect them because you soldered them directly to the controller maybe?

The button-holding thing only goes to WiFi setup mode, it does not reset any other settings. For those, you have to open up the Settings tab.

Once you are in WiFi setup mode, you won’t be able to access it like you normally would through the discovery service until you complete the WiFi setup process.

Once you can get in to the interface, double check the LED settings. Drawing all white is often one symptom of the wrong LED protocol.

It may also be possible your LEDs (or at least your first LED) is malfunctioning, and sending random data to the other LEDs.

@jeff Thanks for the power supply recommendation.

I connected the LEDs using the screw terminals. It’s only hard to access because the board is on the back of something behind a wall, so I can reach my hand it to press the reset button but not easy access beyond that; it’s okay though, it’ll just take some time for me to be able to unscrew the terminals. It’s not a problem though, I’ll try this and report back.

1 Like

@wizard Thanks for the reply! The orange blinking on the board’s LED when I power it on suggests I am in WiFi setup mode, but I do not see the PixelBlaze_XXXXXX device anywhere, so I’m at a standstill.

Yes, I’d limit brightness to 10% or something to diagnose if only I could connect. The LED settings should be correct though as the device has been working properly for about a year now.

Re: The first LED possibly malfunctioning. I did notice that the very first thing that happens when powering on is that the first (or first few?) LEDs shine white/blue for a second or two, then it goes to the issue of all ~100 LEDs quickly blinking 100% white every few seconds. (Neither of those behaviors are part of the programmed pattern, though.)

Any chance that taking a short video and uploaded here is much less effort than disconnecting everything?

If so, try to capture the onboard status LED and the connected LEDs showing the pattern you’re describing.

The forum here can accept smaller .mp4 files in posts by directly dragging them into the message compose field, or you could post an unlisted YouTube video and share the link here.

I will send videos of the board startup lights and the malfunction pattern. Will take me a few days as I’m out of town for a bit. Thanks so much for all your quick responses!!

Do people share their other stuff in these forums too? Might as well make videos of my other pixelblazes to share for fun too in another thread :slight_smile:

Please do! Check out the Show and Tell category!

Hi again @jeff and @wizard, I was not home for a while, but am back now with the videos as requested.

Here are two videos:

  1. The circuitboard status light upon powering up: IMG_2009.mov - Google Drive (Note, after this intro sequence of 1 orange blink then 3 repeated blinks, the status light doesn’t blink anymore)

  2. The blinking white issue upon powering up: IMG_2012.MOV - Google Drive

Yep, definitely seems to be in setup mode. It might by dying once the LEDs power on and preventing you from seeing it on Wi-Fi. You can try giving it. Ore time, turning Wi-Fi off and in can sometimes help, but if you can’t get it to show up you’ll have to disconnect power to the LEDs.

If that fails you can remove it completely, power over usb. Worth a try. Won’t be able to do much of anything until it’s out of setup mode.

Hi @wizard and @jeff, finally got a chance to try your suggestions.

I unplugged, disconnected LEDs, and plugged back in: WiFi setup mode worked again. I simply re-setup WiFi and reconnected LEDs as suggested and all is working again!

It was definitely brownouts due to insufficient power as I played around with a pure white pattern, and at 100% brightness it triggered the brownouts again. I now have it at 50% max brightness.


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.