Left, Came back, I can't connect

I am running Firmware 3.30.
I have never had trouble with my pixel blaze until today. Last night I was messing with a pattern. When I was done I unplugged it like I normally do. Tonight I plugged it in to play with it again and my browser was stuck on the loading screen. The discovery service finds it. I tried restarting it a couple of times but that has not fixed the issue. Now the loading screen does not come up. I tried putting the PB into AP mode but I had the same issue. I was eventually able to connect to its /recovery endpoint. I then set it back up in client mode and reconnected it to wifi but I still can’t get past the loading screen. I have my pixelblaze setup in such a way that I don’t ever touch it. It doesn’t move. I just plug it in and plug it back in so I am not sure what could have happened. It still plays patterns and I can cycle through them with the button. I have also tried to connect from a separate device.

Any further troubleshooting steps would be greatly appreciated. Let me know if I need to provide any more information.

Hi @jdogmcsteezy -

Sorry to hear this happened. I’m wondering if somehow the main app file got corrupted somehow.

First, download the v3.30 firmware as a Signed Transfer Firmware Update image:

v3.30.pb32.stfu (1.4 MB)

Then, connect to your Pixelblaze in AP mode, and go to /recovery.html. In the Recovery Tool’s update tab, upload the firmware file you downloaded above.

Let us know how it goes.

1 Like

Hey @jeff,

That solved my issue! I almost went down that route after reading one of your other replies but thought I would ask first before moving forward.

It’s funny, I sat down to upload my pattern and ask for feedback from the community on how to improve it but then I ran into a connection issue. Ill create another post with the code soon

Thanks again,

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.