Lost Everything

So, somehow I lost all the patterns that were on the pixelblaze when I first ordered it. Anyway I can I can get them all back?

Here’s a repo containing the curated set (thanks @jeff!):

Any idea how they were lost? Deleted from the UI on accident?

Appreciate the info… I should have known to check out GitHub. I think a buddy of mine did something when I let him check it out. Been telling the dude to get one

BTW the latest version of V3 has a backup restore, get a backup before lending it out again and no worries.

Actually, I wanted to play with the new archive feature, so I ran it on one of my Pixelblaze v3 which I believe is basically all the stock patterns. It’s linked here below, but remember:

  • Requires the Pixelblaze be upgraded to firmware >= 3.24 first
  • Upload from the bottom of the Settings page
  • Settings encoded in this backup (you can overwrite these, but just beware what it will boot with):
    • 10% brightness limit
    • 100 LEDs, WS2812, RGB
    • Fastest CPU

Grab the .pbb file here:


Gotcha. Will do. Thanks you!

1 Like

whats the process for doing this? i can’t seem to get it to work.

You need to be running v3.24, then go to the settings screen. Near the bottom you will find a restore button. Click that, and a modal pops up. Select the file, and click restore.

1 Like

So, I got all the patterns back but none of the sound ones work. Any ideas?

Check that the sensor board is attached, and recognized by Pixelblaze. You should see this on the very top right corner of the page with the status info:
Screen Shot 2022-05-11 at 6.59.07 AM
That is showing the Sensor Board 1.0.

The sensor board will only use one audio input at a time, so the mic won’t pick up anything if a cable is plugged in to the aux input jack.

Using the new gauge control, you can have a simple VU like display on a gauge to see it react to sound:

export var energyAverage

export function gaugeEnergyAverage() {
  return energyAverage * 10

1 Like

So, it looks like the sound board is recognized. But I’m still not getting anything to happen when I choose the sound reactive patterns.

What do you get running the above pattern? Is anything plugged in to the aux jack?

Nothing plugged into audio jack… I can never get that to work. I’m not getting anything

If you run a pattern with all of the sensor board exports, then turn on the Var Watcher, does any of it respond?


export var frequencyData
export var energyAverage
export var maxFrequencyMagnitude
export var maxFrequency
export var accelerometer
export var light
export var analogInputs

Are the audio related variables doing anything at all? Does the accelerometer, light sensor, and analog inputs have any data and respond to stimulus? Can you do that and get a screen shot of the Vars Watch display?