NEW PBV3 + APA102C Troubleshooting help

Hello I have a new PBV3 and new 60led apa102C strip. I get a random led displaying each time I power up the strip and PB(no data being transmitted?). I believe I have either a problem with my strip or a problem with the data/clock outputs on the PB but I need some help determining which one is the problem.

Wiring is correct, data to data and clock to clock. Direction of strip is correct.
Tried powering from USB and 2A 5v 110V wall adapter.
Checked voltage at end of strip >5v. Jumpered v+ to end of strip and ground to end of strip. Jumpered ground to PB.

Software: I am able to connect to PB just fine. I set the led count and type to apa102.
Tried adjusting data speed and color order. PB is displaying the pattern at the top, so I assume it is outputting data and clock.

Any help would be greatly appreciated!

I’d say you need a different strip to check the PB out.

I made some progress.
I tested with a ws2812 and it works, so I believe I can assume that the PB data output is working.

I switched back to a smaller section of my apa102C strip and I am now only getting only the first LED to light.
It does light according to the pattern, however, only one led of the strip is lighting. I set the count correctly.
My mapping is set to the ring.
Could this tell me that I have a bad led? (the second LED??)

I appreciate any suggestions!

1 Like

It is possible you’ve got one or more dead LEDs. But before declaring them dead, check the connections to the strip – remove whatever plastic coating is on the strip end of the connector and make sure the solder joints there are in good shape.

1 Like

You were correct. It appears that I have a very poorly manufactured strip. Many of the LEDs were not soldered securely causing many problems. I will attempt to return the strip. Thanks to everyone for your help!