No output to the blaze or the preview

Ok so I haven’t been getting any output to any LEDs and it worked the other day. I noticed that this bar is getting no response or showing any pixels moving. I’m sure this means a couple of things but I need help narrowing it down.

I realize this means there’s no output, but not totally sure why? I’m using WS2811s (singles, not strips) but I tried switching over to 2813s strips which I know are good and not getting anything on those either. I’ve swapped around LED types in the settings and number of LEDs but not getting any response. I’m using a 5v 60 amp seperate power supply and not using a expander unit. I’m definitely getting voltage to the LEDs.

Any ideas? Is this a hardware problem with the blaze? Have I messed some options up somewhere? Lemme know what other info you might need and I’ll get it to ya asap.

Hi @Shakes999 -

That grey bar usually means the preview bar has been clicked to disable it. This is useful in certain weak wifi conditions. It’s unlikely to explain why you’re not seeing output.

Can you screenshot your entire browser while on your Settings page? There’s a few things we could see in there that could cause this: global brightness slider, brightness limit setting, auto-off schedule, and perhaps LED type settings (No LEDs). I’d also like to see if the word “Connected” is in the status bar.


There ya go! Connected is there thankfully. I currently still have it hooked up to ws2813-150 string of LEDs for testing purposes and checked the copper strips for voltage and we’re good there. I’m able to get a single flash of lights when I connect the data for a split second but then it goes dark.

Feel free if there’s anything else you need. I’m on my 4th PB and they’ve all been really solid so this one has been confusing me especially since it was working before. In all fairness I don’t have the best work station so I’m not ruling out maybe I fried something on the board but may as well rule out user error!

edit Much like when I spent 25 hours trying to backlight my TV, it just kinda started working again. So preview is back instead of just being grayed out no matter how much I clicked it and the strips are working again, though I’m still getting nothing for the single ws2811s so progress! I didn’t really do anything, didn’t reboot and just kinda swapped through LED types for the 50th time and it started working again. I’m a bit confused why the strips work but the singles won’t but I guess I’ll fumble-f with that now and see what’s going on.

Thanks for the help anyways! It’s appreciated! Now back to this 8x8x8 cube causing my hair to fall out from stress!

Hi @Shakes999 ,
I would double check the wiring, test continuity, etc. Soldering and screw terminals are common problems and can show up intermittently. If you post a photo of the soldering and wiring, we might be able to spot something. Also, if you do have a separate power supply for Pixelblaze, be sure to connect the GND on both. The ground has to be shared for the data line signal to work.

There ya go! Not great but not terrible imo? What parts of the LED should I be checking for continuity or do you mean the PB? I do indeed have a shared ground so that should be no issue.

As of right now, I’m just touching the data lead to the Data in pins to see if I can get any sort of response and nothing. I’ve tried testing individuals also and still nothing. I know you just wanted pictures of the PB soldering but just to give a idea of what I’m working with.

Honestly, I think I’m at a point where I’m starting to think the 2811s are the problem. I got them to light up when I was testing them one by one but now it’s becoming more hassle than it’s worth especially since I can get the ws2813s to work now so in my eyes, they’re starting to become suspect.

This looks like a Pixelblaze V3, right? (yes - I just checked the photo - it’s v3.4). I have one string of lights that will not work on a V3, but will work on a V2 at all but the fastest and slowest speed options. All my other strings are happy with either V2 or V3. The V3 board drives the LEDs at pretty much the same speed as the fastest speed on the V2. Do you have access to a V2 board that you can try set to one of the intermediate speed settings?

I do not! But I think I’m going to pick up a V2. I’m also gonna pick up another Pixelblaze V3 so I can have one for troubleshooting and so I can rule out the PB V3 as the problem. I do enough projects with them that I’ll end up using it sooner or later anyways.

Thanks for the photos! Yeah, not bad!

There’s a bit that doesn’t look quite right in the last photo, or perhaps I’m missing how it’s set up. Those LEDs are WS2811 / WS2812 compatible addressables, yeah? They should have at a minimum 4 pins (+5v, GND, data input and data output). It looks like you have power, but I don’t see a whole lot of data connections. There’s one with a pink wire between 2 LEDs, but I don’t see any wires connecting to the Pixelblaze’s blue data wire. How do you have those wired up for data?

Oh sorry, there are indeed 4 pins on it but it’s just impossble to see the pins in that picture. Here’s a completed one where the data is connected. That particular board the datas aren’t wired in yet, I’m just touching a wire from the data connection to the data-in pin so I can see if it even lights up or gets a reaction.

I’ve only finished one of the planes with data. I figured I should test before going further and that’s where I stand for the moment.

On the pic with the Power Supply… all the ground leads are under the same screw terminal… but two yellows are under the first screw, and one yellow is unde3r the second screw. Is that deliberate? (Are both screws with yellow wires the same part of the PS? That is, are the two terminals the SAME 5v or 12v? I can’t see any legend on the PS to tell…)

They are all the same PSU! I was just being labsent minded with where I landed them really but it’s all the same. So minor update with all this, I think the problem is my soldering or the LEDs at this point. I’ve been getting incredibly inconsistent results with them. I’m doing a new single row with LEDs I just tested and know for certin work and then see what my results are if they still do after soldering. Either these things can’t handle soldering at all and I’m cooking them (I’m not great at soldering so I can’t rule out it’s my fault), or they’re just crap. We’ll see what happens shrug

Addressable LEDs are pretty temperature sensitive when exposed to air, at least the surface mount stuff. I have to dehydrate them (bake them at 70C for 48 hours) or they will become damaged when soldering.

You could try dropping your iron temp a bit, and with practice you’ll be fast. Until then just let em cool if you’ve had the iron on them for more than a few seconds before continuing.

You can also try dehydrating, but without a temperature controlled method it’s easy to under or over bake. You might have luck with a cheap food dehydrator, but often these don’t get hot enough.

Wizard’s right… an adjustable controlled-temp soldering iron will be a valuable too if you’re going to be doing many joints (like a big matrix with 4 pins per pixel ;-),

When I’m making things, I usually cut pixels from 60-per-meter strips with the 5050 pixels. That strip doesn’t dissipate much heat, and will carry it to the surface mount parts. To compensate, I’ll quickly “tin” the three “input” contacts, and set it aside, and tin the inputs for all the pixels… THEN I will go back and tin all the outputs… by that time, I’ll ‘stitch’ a pair of pixels together (heating the ‘ins’ on one and the ‘outs’ on the other, and set the pairs aside. Finally, I stitch the pairs together. In all this, I’m only quickly heating three contacts on each pixel, and I test strings when they get to 14-20 in a string to check for failures.

Tinning the leads/pads/wires means that the solder bond will take more quickly when I join two things. That means less heat spreads in the parts. On your LED pixels, consider juts tacking all the positive leads, up and down the line, then go back and tack the negative leads, and then test one pixel at a time to see if you get a better “yield”? :slight_smile:


Just a comment on soldering temperatures. Until you’re well practiced, it is almost as easy to damage things with too low a temperature as with one that is too high. If it’s too low, the joint and solder won’t get heated enough quickly, and then more heat will spread to places you don’t want it to go. The other tip I would offer is to make sure you have good quality solder and flux. Modern lead-free solders are especially fussy when it comes to flux in my experience.

I have to say that I think where I went wrong is because I shake, like, a lot, I’ve been using the iron to melt the solder on to the components instead of, what I found out was the proper way, is heat the components until the wire melts the solder. So there is definitely some wonky soldering going on.

But despite that, I doubt I did a bad enough job that ALL of them got fried. Once I got in to the flow of things I was able to move pretty quickly on each joint and I actually did it the way that Zonker suggested which is to just do all the positives on one row and then move on to the next row. So I’d like to think that at least SOME of them would work. The holidays started so I’m gonna dump a few hours in to troubleshooting tonight.

I just got paid so I’m gonna pick up some WS2812B pixels I was FINALLY able to find and I’m gonna start over. These 2811s have been nothing but trouble (Oh! and the data sheet provided had the pins labeled wrong. It should have tipped me off there might be problems) so we’ll see what happens.

1 Like

Sorry, one more update and then I’ll let this thread die. Because now things are actually working? I simply switched over to using the output expander board instead of just straight off the PB and things are lighting up. I’m somewhere between relieved and incredibly frustrated that that was the solution especially since I had over 40 hours in this already.

I also have no idea why that works when it didn’t straight off the data of just the PB but I figured this might be pertinent information for future threads and trouble shooting.

Thanks everyone for the help! I’ll pop back around (in a new thread lol) when it’s time to decipher coding for this beast.