No Pixelblaze controllers have registered yet

I have three PBs that have been in CLIENT mode for a couple years. I make edits to the patterns every once in a while. I haven’t accessed them via for a couple weeks. Today, they do not show up at all; I just see " No Pixelblaze controllers have registered yet." I have tried three different devices, all on the same WiFi.

I’ve had this issue on and off before. Sometimes, only 1-2 of the 3 will show up. Typically, unplugging/replugging the undiscovered ones and waiting a few minutes does the trick. But I’ve tried that several times now and I’m still at 0 of 3 showing up as discoverable.

I don’t recall their exact firmware, but they were all updated within the last ~3 months.

What should I do? And any tips to avoid this in the future, like maybe writing down the IP of each one to connect manually?

Things I’ve already tried:

  • Unplugging/replugging in PBs
  • Toggling WiFi on/off
  • Tried multiple devices
  • Ensured I’m not on VPN
  • Waiting a few minutes after each of the above

Hi @bunbunfriedrice ,
For the discovery service to work, the device accessing the page and the Pixelblazes need to have the same public facing IP address. For most folks, just using the internet from the same location is enough. Some advanced networks can use multiple outgoing IP addresses, this is more common in larger organization offices.

It’s also possible that a phone is preferring to use cellular data over WiFi for some reason. For phones, I would try turning cell data off momentarily, checking the discovery page again, and seeing if that works.

iOS Safari, in some versions of iOS, has a feature that can cause issues with discovery. It can mask your external IP address by basically using a VPN or proxy, though they don’t call it that. In Settings → Safari → Hide IP Address, set this to Trackers Only or Off. The “Trackers and Websites” setting is what causes issues.

Various security products can also end up proxying your browser requests.

There are some alternatives to using the discovery service as well. Your router should have the option for assigning static IP addresses. The Pixel Lights app, and Firestorm, as well as any Pixelblaze you can find should be able to find the other Pixelblazes on the network.

I hope that helps a bit, let me know what you can find! If you still have trouble getting the discovery service to work, let me know and I can help troubleshoot further and see what requests are making it to the discovery service.

1 Like

I’ve tried on multiple devices (Windows, MacOS, iOS) and multiple browsers each. No VPN or anything. All used to work, now none of them do. So I’m guessing something is up with my router.

My router has separate networks for NAME, NAME 2.4 GHz, and NAME 5.0 GHz; I thought it might be an issue of which one of those I was on, but I believe they all have the same public-facing IP address.

Would it help to put the PBs back into WiFi setup mode and try again? And if so–I would not lose the programs on them, correct?

Wi-Fi setup mode won’t hurt, doesn’t delete patterns.

If your router sets them up with different subnets, that is local ip address space, and doesn’t route/allow traffic between them, then that would cause connection issues, but they would still show up on the discovery service.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.