Patterns not sending to LED strip

I powered the PB by usb, connected led strips (WS2812B), got connected to the WiFi, and brought up the web interface. I went into settings and selected WS2812B and # of pixels.

When I went into saved patterns to preview some patterns, nothing changed. The LED strip was white. I tried clicking a few different patterns but nothing changed.

Anyone know what the problem may be?


Hi Oran,
This is with the output expander right? If so, the Pixelblaze output type should be set to Output Expander. Then you can add a board config using “add board” button, then configure the expander channels as needed.

No this is just the PB I’m using, (the other post RE wiring with the output expander is for a different project).

The LED are only bright white from when the usb is connected until I unconnect it, no matter what. I tried to lower the brightness, preview saved patterns… but it just stays white.

Just looking at the setup, are these additional connections I need to make?

Hi @oran,
No need to make extra connections, those are connected internally and you can use either.
Remember don’t connect USB and external power at the same time! How do you have it connected and powered?
Can you get a screen capture of your settings screen?

Its powered by usb only.

Heres the settings…

Change it to buffered WS2812 - its always faster and has less issues in general.
Try different data speeds. Smaller numbers might help.
Is it an RGBW? You can try an RGBW color order setting.

Spot on, that was the culprit!

The response with help and support here really is impressive, it’s very much appreciated.

1 Like