PixelBlaze no longer recognized by discovery service

It’s been months since I been able to connect via Discovery Service. PB is NOT discoverable and I don’t know why. I’ve removed it from an enclosure and it is connected via USB cable onto one of my iMac ports and it is not Discoverable. Pixelblaze_68968D IS listed in my WiFi networks and when selected I just get the spinning box. Any ideas?

Hi @FredEBear -

If you see Pixelblaze_68968D listed in your available WiFi networks, that means the Pixelblaze is in AP mode (or the initial setup mode). The discovery service only works to help discover a Pixelblaze that’s connected in client mode to a wireless network that has access to the internet.

To get client mode working again, we’ll need to get you past the spinning cube and into a WiFi setup screen. It looks like you’ve already explored some of the best ways to do this with other people trying to help. From re-reading that thread, it looks like the collective wisdom is:

  • Have a stable wifi connection between computer and Pixelblaze
    • The computer and pixelblaze need to be physically close. Your WiFi router doesn’t matter for this part.
    • Have the Pixelblaze out of any enclosure
    • Verify a clean 5VDC supply power. Disconnecting LEDs and powering then by the micro USB is usually a good way.
  • Reset the Pixelblaze into WiFi Setup mode by holding the button for 5 seconds while powered.
  • Being patient, wait for the open Pixelblaze_XXXXXX network to appear. You must connect to it.
  • If it doesn’t open the page automatically, manually go to
  • At this point, if stuck on the rotating cube, try loading or to reload or update firmware.
  • Once you are able to connect to the setup screens, be sure the Discovery service is enabled, and be sure you’re running the latest firmware. It’s been a while now, but much older firmware had more wifi hiccup issues.

Hope this helps!

Thank you for your fast reply. I don’t like being the bearer of bad news but NOTHING you suggested worked nor have any of these steps worked over the past 2 months. I believe my PB is somehow broken. I’ve waited over 20 minutes for a connection, which is quite strong and my PB is only about 4 feet from my main router.

Just to check in and be sure we’re understanding each other - most of the steps are centered around making sure you can connect to your Pixelblaze in WiFi setup mode. The distance to the router doesn’t matter for that part (the router isn’t being used in this type of connection), but distance between Pixelblaze and computer does matter.

Thank you. It’s as far away from my computer as the length of the USB cable it’s attached to. Measuring distance I would say between 3 & 5 inches as the cable isn’t extended and the PB board is quietly sitting on the same table as the iMac.

Has everyone given up on me? Still can’t get Pixel blaze recognized on this site. Like I’ve stated before, it appears on my WiFi drop-down list. Most times I get the spinning box but that’s it.

I don’t know if you’ve tried, but this might help. I’ve had PB’s that work fine with no issues for me (Windows PC and Iphone), and then when they are set up at another location (Android tablet and phone) they get the spinning cube on the loading screen.

So some of the issues I have seen have been “fixed” by using a different device to get it connected to the network, and then once connected using a different browser such as Firefox gets it past the spinning cube screen.

I’ve also seen issues getting the PB connected to the network when the modem has a combo 2.4/5G signal. Instead of it broken into the 2 separate options. Sometimes it’s easy to get it connected but then have problems later on, giving you the spinning cube. I’ve gotten around this with using a cheap 2.4GHz only router.

Hopefully there’s something in here that can help

Hi @FredEBear ,
The discovery site isn’t supposed to find you controller while it is showing up in your wifi list.

You have to select it in the wifi list, then configure it.

If, when selecting it from your wifi list, a window pops up and you only get the spinning cube, you have to try some hardware modifications, like disconnecting LEDs, and removing the controller from anything that might be blocking the signal.

FWIW, I discover.electromage.com shows nothing on my personal iPhone via Safari. In private mode as well. “No Pixelblaze controllers have registered yet.”

But discovery on my macbook works fine, as well as on my wife’s iPhone!

Browsing directly to the IP address works fine on my phone.

So something weird is going on with just my personal iPhone and the discovery site.

I’m on firmware 3.24

@Whitespace The discovery service works by matching your IP address. So I think your phone is deciding not to use your local wifi internet for some reason, and sending the request out cellular data. This wouldn’t be the same as @FredEBear’s problem.

I just tried that now and still didn’t find anything. I even went to http://discover.electromage.com/?foo on my phone to maybe break caching but it still found nothing.

@Whitespace, tried which exactly? Turning off cellular data? If you have a VPN running, that could also change your IP.

The page makes an API request, no caching involved.

I tried turning off cellular data. No VPN installed. iPhone 13 Pro Max. iOS 15.5

Could you try one of the IP reflection sites (“what is my ip”) on both your desktop and your iPhone? I’m curious if they’d return the same IP.

Aha! It’s different even when I’m on wifi and I have cellular off.

I forgot I enabled “Hide IP Address” in iOS, so they’re proxying my data! It was enabled for “Trackers and Websites” which of course would break the discovery service.

I turned it off and now my IP is the same as my home IP! … and it still doesn’t work! :exploding_head:

After a restart of my phone now it works though. Thanks @jeff !

Interestingly, once I turned on cellular data it stopped finding my PB. If I disable cellular and refresh it still says “no PB controllers have registered yet” Very strange.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.