Powering Pixelblaze from power supply not working? Only USB

Hi Wizards,

I’ve used the pixelblaze before successfuly, but only with USB power.

For my current project, I need more power so connected at the end of the LED run… but when I tried this, it doesn’t turn on.

I then connected it to the power supply terminals (it’s a generic 5v 50a one) with a short cable (so V+ to Vin and V- to GND only on the pixelblaze) but it doesn’t turn on. I then tried with a second board, and same result.

I think I’m missing something obvious! What’s needed to be done to get this powered from my 5v supply?

Hi Rob!

OK, the first thing that came to mind was when I recently ordered a new Mean Well LRS-350 and forgot to switch the input voltage on the side down to 110V from the international 220V standard.

Are you getting a green light on the supply (if it has one), and can you use a voltmeter to verify 5V between the V+ and V-?

Hi @aiotea ,

If Pixelblaze powers up and runs via USB (and it is a handy way to verify PB itself), then power to the VIN & GND will generally work as well, as long as power is getting to the board. Those are connected directly on the PCB, so there’s very little to go wrong on the board.

It’s not uncommon to have a bad solder joint or to have too much insulation on the wire.

Adafruit has an excellent visual guide on what to look for when soldering and common soldering problems:

The other common issue can happen if the wire isn’t stripped enough when inserted into the screw terminal. None of the insulation should be inside the terminal, and ideally ends right as the wire enters.

If you send photos of the screw terminals, both the soldering and wire, we can help remotely diagnose those too.

1 Like

Thank you both for the replies! I double checked everything, and eventually the Adafruit Guide made me realize some of of soldering did not penetrate enough.

I’ve fixed the soldering and now it’s powering up!! So problem solved. :smiley: