Stuck on Spinning cube loading screen

I don’t see a solution to my problem here even though the problem is described here.
Spinning cube - that’s it! No SETTINGS access so I can’t reset PixelBlaze. Pressing button for a reset doesn’t work. Removing power, waiting, restarting does nothing. It connected just once this past week. PixelBlaze works just fine, I just can’t modify the programming as I can’t access the site. I must be missing something here but don’t know what it is. Using Firefox (sometimes Chrome) and both state that “Sorry, I didn’t find anything here” but the Pixelblaze_68968D IS listed under the WiFi icon! And, when I select it the spinning cube starts up but NEVER connects.
Any helpful solutions would be most appreciated.

When this happens to me, /?setup or /recovery.html usually does work.

Thank you for your reply sorceror however I don’t know where you type these commands.
“/?setup” would be typed where? Or “/recovery.html”, also where?

They are paths in the URL, as in http://192.168.0.123/?setup or http://192.168.0.123/recovery.html

Tried them both and nothing worked. Still the spinning cube but the Pixelblaze_68968D is listed under the WiFi icon. So my iMac sees the PixelBlaze but can’t connect!
Strange indeed.

i don’t know what browser you’re using but i’ve found that Safari and PB’s web interface don’t get along well, i’d frequently have long pauses on the spinning cube view.

switching to using chrome with PB cleared everything right up for me.

1 Like

Hi @FredEBear ,

Just to be 100% clear, you mean it’s connected, not just listed? There will be a check icon next to it like this (in this example, Applesauce2):

wifi connected

If you hold down the option key when you click on the wifi icon, you can get a lot of detail for the connected network, like this:

wifi detail

Can you tell me the RSSI , Noise, and Tx rate for your Pixelblaze_68968D network?

A few things to try:

  1. Close your browser tab/window before trying to load the interface again. Sometimes reloading the page works, but sometimes browsers are stubborn. Either way you have to fully load the page again, just having it open while reconnecting to Pixelblaze’s WiFi may not continue the loading process.
  2. I would definitely update to the latest firmware when you get it back online. The new version has longer timeouts for some things when WiFi is slow or having issues.
  3. Disconnect LEDs, move to better wifi signal, do whatever you can to improve the RSSI and Tx rate.
  4. If it’s in setup mode, and if when you connect to that wifi network, a pop up window with the spinning cube appears, try this: close that window, and load a fresh browser window/tab and navigate to http://192.168.4.1/recovery.html You should see the plain white recovery page where you can manually enter your wifi information. That should get you back up and running in Client mode, and you should no longer see the Pixelblaze_68968D wifi network, instead you can use the discovery service to find its IP address on your local network.

In general, you don’t need to reset Pixelblaze back to setup mode unless you need to change how its wifi is connecting. As long as Pixelblaze is connecting to your router (in Client mode), or you are connecting to Pixelblaze’s AP network in AP mode, you don’t need to put it back into setup mode.

Keep in mind there is always 2 steps to connecting to a Pixelblaze that is in AP or setup mode. You must first connect your computer to its WiFi network. The second step is loading the page in a browser (which should automatically happen in Setup mode, a network login popup should appear). Both of these could be considered “connecting” so it’s important to be specific when you communicate connection troubles to us.

1 Like

Just to be clear: PixelBlaze_68968D is listed under the WiFi icon, but NOT connected.
RSSi -37 dBm
Noise -92 dBm
TX Rate: 65 Mbps
The ONE time I did manage to latch on, the first thing I did was to update.
In order to do step #3 I must unplug and relocate my PC to another part of the house.
I CAN tap the Pixelblaze_68968D WiFi site and immediately get the spinning cube but can’t connect. Discovery still says “Sorry, I didn’t find anything.”

Hi @FredEBear ,
When Pixelblaze is in AP or setup mode, you MUST connect to its WiFi network to do anything. Only once you are connected will you be able to load the http://192.168.4.1 page. If you disconnect from that WiFi network for any reason, the page will no longer work as it has no way of communicating with Pixelblaze.

“When Pixelblaze is in AP or setup mode, you MUST connect to its WiFi network to do anything.”
Yes I do understand. What I’m not getting through is that with a clean Chrome browser and running Electromage.com, Discovery, and being just 8 feet away from the whole house router (with very strong WiFi signal), am unable to “latch” onto Pixelblaze_68968D on the WiFi drop down icon. THAT IS what’s happening. I’ve tried everything suggested here all to no avail. Like I stated before, I was able to connect (as usual) and update PB but since then no success in connecting my display to Discovery.
Thank you for listening.

One more thing: from Discovery, “Give it a minute after powering on and reload this page. If that still isn’t working, try setting up WiFi again”.
How IS this possible if I can’t connect? Is there another way to setup WiFi without Pixelblaze connecting? When I updated PB I made sure Discovery mode was set up. It has since stopped being Discovered but PB still runs my display.

Hi @FredEBear,
I think there’s some confusion going on with how all this connects.

If you see Pixelblaze_68968D in you list of WiFi networks, then the PB should be in AP mode. With the PB in AP mode, you won’t see it on the discovery site because it’s not actually connected to the internet.

To connect to the PB, you need to disconnect from your home WiFi and connect to Pixelblaze_68968D WiFi. If you computer will not connect to this WiFi, try using a phone or other device.

Once you connect to the WiFi named Pixelblaze_68968D, you will not have any Internet. Open a browse and go to http://192.168.4.1 This should now load the spinning cube and advance to the web interface and setup page.

If and when you connect to the PB and get to the WiFi setup page, change the settings on you PB and connect it to you home WiFi. Once this is complete, you’ll be able to use the discovery service to find the PB on your home WiFi network.

I hope this clears some things up. Maybe it was already clear and I’m just misunderstanding what’s being said.

–Earl

1 Like

Yes I’ve tried and tried and tried this approach. Using my iPhone I get the “Loading…” screen (spinning cube) and that’s it! After an hour I usually give up because I know it will NOT connect me to the Electromage page on either my iPhone nor iMac.
Thanks anyway.

Hi @FredEBear

It sounds like something is interfering with the WiFi signal significantly. Try removing it from any devices or enclosures, and leave the LEDs disconnected.

Even in this state, I would expect that the recovery page could work, so I would give that a try. If you get that to load, send a screen shot or copy of the info it displays.