Updating Pixelblaze firmware problems - timeouts and/or errors

My situation is identical. Started to run slowly. I had web access for awhile. Would make it almost through updating and then say Internet error. Now I can’t even get that far it just goes to with a blank screen.

Few things I noticed. Before it stopped working completely I noticed that it had reverted to a different LED type in settings as well as back to 100 LEDs. Also memory did show -k so I’m assuming that’s the root of the issue.

I tried to do the delete route with curl But I get an error that says protocol HTTP not supported or disabled and libcurl

  • figured out that last part was syntax. Didn’t realize windows require double “. Right now I have it at the update screen but it just gets stuck and then reverts back to /?wifi

So here is where I am stuck. Got it back on my network. Discovery shows an IP. I can go to update again but it fails to update every time. I have done the delete index, assign network SSID and Passcode… just can’t get it to take an update.

Can you ping the IP?

I’ve not been able to get client mode to work again on the one that is out of space but I can ping the IP when connecting to the AP.

Can you get it to take the AP config?

curl -i -d “mode=AP&ssid=pb3&passphrase=password&discover=true” -X POST

I’d guess the ERR_Connection_reset is a symptom of underlying network confusion. Not PB specifically, more related how the underlying network is handling some of the config changes. I’ve seen this both unrelated to PB and with PB (once). Reset the network (reboot everything). or check the DNS caching/configuration, or check IPv6. MAYBE…

Looks like you might be on the right track

Got it to take the AP config. Connect to the AP, ran update, and same failure.

@array, @haro ,
The advice on this thread is a bit out of date with V3.18. The version shown on the discovery service is showing 3.12, so the update didn’t take, but you should have a /recovery.html file installed if you started an update.

If you are seeing it “forget” LED type and set pixels to 100, then there’s a good chance you have a power issue, or possibly something is causing PB to crash. See this post. Power issues can cause all sorts of chaos, mess with WiFi, cause brownout resets, and could be a source of flash corruption.

Free space shouldn’t be nearly as critical as 3.18 updates will free space first, and 3.18 will install a recovery page so you don’t have to do any hackery with curl to set up WiFi if the index page is somehow lost.

First, I would disconnect the LEDs and try to stabilize power and WiFi connectivity. I’ve had power supplies go out or get weaker over time. You can also try removing PB and powering it via USB so that you can get back to a working setup, and experiment from there.

Second I would try the /recovery.html page, and see if you can get it to update from there. If you still can’t even ping it, then it could be a router issue, and power cycling your router can help.

Third, if you can get 3.18 installed but things aren’t quite working right, I’d try holding the button to reset it back to setup mode. In 3.18 the nonvolatile memory (NVM) where WiFi credentials and other settings is stored will be cleared/reformatted. This may help address some issues if the NVM is corrupt. You have to be running 3.18 though.

I could never get out of 3.12.

I’m pretty confident mine was memory related because I had just added more patterns and realized that it was suddenly becoming unresponsive.

Also, mine said memory -k

I don’t think I have a recovery page with 3.12? I can only get to the /update screen now and it looks like it starts to take and then just says connection reset. This is with an AP connection. I own two PB and I’m tempted to swap my good one out but I have a big map on my bad one and I’m not sure if I’ve lost that.

Here’s a video showing no luck with the update. I’ve tried it through my PC and I’ve tried it through Safari on my iPhone every time it looks like it has a time out error.

Got it on my network. Same outcome.

The connection was reset.

I did get recovery up though. You can see memory now.

It makes it to file three out of four and then just times out.

Try putting it into AP mode to update. I also found /Update was the last page i used with 3.16 before it started working again vs using the recovery mode update tab.

wonder if 3.16 ultimately worked because it was the last version running briefly. ??DONO?? both versions .16 and .18 said success/rebooting more than once via the /update page before i found something running.

Ultimately some combination while in AP Mode, deleting patterns, and using the /Update page got the one i had filled up running again.

Sometimes i could not find this /update page , it would either time out or error out with a connection reset. but when i did find it, /update always provided a success and reboot message where as the Recovery Mode Update tab seemed to grey out the update button and sit there fore a few beats before the browse button would be active again.

It seemed hard to delete the patterns. Issuing the URL checked it several times, did not delete patterns. It almost seemed easier to delete the examples than ones i loaded. Never did figure out the trick when it deleted or when it just pretended to delete. But eventually removed enough to permit the update to succeed.

Was not sure if i needed to be in “setup mode” bright orange light or not. I tried it both ways. Eventually found it did not need to be in setup mode since i could only set the AP ssid/pw then restart and connect to the AP i set using CURL. the web pages were dead for setting the WIFI config in my case…

I have tried client and ap. No success either way. Running off USB now. Reset the router. Tried it with Safari. Tried it with Firefox and extended the time out. Nothing works. When mine became unresponsive I started to delete a few patterns but I can’t even access anything at this point to free up memory. I feel stuck at this point.

I did update my V2 tonight which was seamless.

@array ,
Sorry this one is giving you so much trouble. If you want to swap it out I can send you a replacement and check out your broken PB and try to see what happened. Maybe I can recover it and get you your patterns and better understand what caused the failure.

BTW the storage free info will only report properly with newer versions of the firmware installed. Since you didn’t get that far, the size never gets updated/shown on the recovery page.

@haro ,
Glad yours is up and running again! Most of the web API is unavailable in setup mode. You’d have to be in client or AP mode to access the delete API. Older versions wouldn’t let you get to /update in setup mode, while newer versions of the firmware will. I hope that explains some of the issues you had.

I’m certainly up for troubleshooting. I used the 2d pixel mapper, the longest part is just clicking 600 times. :joy:

It appears to be deleting, so let me try to delete a handful more tonight and then I’ll try to update. I’m not making my own patterns, just pulling in ones others have made, so nothing lost there.

I’ll let you know if fail to fix it. I have video of it sticking on a pattern before all was lost. It was also right after I installed the doom fire pattern. :man_shrugging:

I think this is the moment it froze.

Sorry, I missed the part where you had a map you needed! Try to get the map source at the /pixelmap.txt URL. That should come up as long as you aren’t in setup mode.

Also noticed in your video you are uploading 3.16. Prior to 3.18 updates would try to install the full web app before deleting the old one. If uploading update files manually this v3.18 update file, which frees up space first (by replacing the main app with the recovery app) and should apply more easily than v3.16.

We can also try updating just the firmware, skipping the web app install, which will enable some more features in the recovery page like the free space reporting firmware update status even for uploads. It might not directly resolve the issue preventing the web app from updating properly, but could give you more tools. I’ve made a special update file for you here.


Was able to get the partial uploaded. From there was able to get the full version uploaded. Able to get it on my network. Downloaded my LED map (thanks for that). Can’t get it past recovery to the cube again though. Sitting at 535k free now though.

Uploaded the full 3.18 update via recovery page, and that took, but you can’t load the interface? Can you at anything in your browser console?

It just pulls up the recovery every time but it assigns an IP on my network just like it should. I was able to delete a few Patterns before 3.18 so I’m sure I can get back to that with console. Just no loading screen.

I don’t know if this means anything but when I go to reset the network the LED will blink some thing like eight times. I believe it was five rapid blinks A pause and then three more before going back to the dimmer orange version. I will have to push it a second time to actually get it into set up mode

Try uploading 3.18 on the recovery page. It should give you status messages. Does it complete or give an error? When done it will restart, give it a minute. After that go to / without the recovery page.

If the update installs the index or / page should load the app. If you get stuck at a spinning cube there, open the browser console and reload the page. Give it a minute if needed. Does it show anything?

It won’t complete if you try to do it from the recovery page you have to do it from /update (which it will complete if you do it that direction). From the update page it will say success and it will restart as intended but it will fail every time from the recovery page as if it’s timing out.

Here’s a video

1 Like

Yikes. I’ve never seen it take that long, write that slowly, especially for a local upload.

I think your PB might have a bad flash chip or something.

Now that you have your map, can I send you a replacement?

1 Like

Sure, I can send this one back.