V3 Pico Stuck in WiFi Setup

So I bought some more PixelBlaze boards recently and decided to buy a few Pico boards. Unfortunately I’m having trouble setting them up.

I turn on the power 5 volts and the unit starts drawing current (40 mA turning up to 150mA, seems kind of high). I find the Pico ID in my list of networks and connect. This brings up the spinning cube and then the WiFi page.

This is where I get lost. The page asks for an SSID and Password. What am I supposed to do here? I’ve tried several things but when I ask to Connect I get an error.

With the standard PixelBlaze I’ve always ended up on a page that allows me to name the thing and give it a password. I’ve always set them up in AP mode (whatever that means) and things have always worked.

By the way I’m basically ignorant of a lot of computer/network terminology so any help assume I’m on a very basic level.

Cheers.

Hi @alan_sailer ,
On the WiFi setup page there’s a drop down where you can select AP mode. Then give it a SSID (wifi name) and password (at least 8 characters, just remember it you’ll need it later!). Then click submit, the new network should show up!

  • If you want to create a network use AP Mode (AP means access point, a WiFi jargon term).
  • If you want to connect to an already existing network, use Client Mode (again, jargon).

Both options are spelled out in the dropdown menu. The help text for the form also updates based on the selection, so if you want to know what does what, give that a full read after you change the drop down menu for WiFi Mode.

Yes, 150mA is normal, plan on up to 175mA for AP mode. Most of that is from WiFi. There are settings that will let you shave off a good handful of mA by reducing the CPU speed. You can also have it disable WiFi on startup to save a ton of power though that makes it trickier to connect later (gotta hold the button down). With both options it can run on as little as ~31mA at 80Mhz without WiFi.

Thank you. I did not notice the drop down menu.

I did use the drop-down menu and changed the name and entered a password. The page was happy. And the new name showed up on my computers WiFi network list.

However when I try to go to the newly established name and connect it tells me it cannot find the PixelBlaze.

I’m sorry for any incorrect terminology.

What do you mean:

What is telling you this? The discovery service? That won’t work with AP mode.

If you set it to AP mode, go directly to the IP address:
http://192.168.4.1

Mr. Wizard,

As I mentioned, I’m a total dope with terminology.

After several tries (avoiding the discovery service) I was able to connect. I’m not sure why it was so much harder with the new V3 set-up but it was difficult.

Thanks for your patience. I know trying to translate my noob-glish into something you understand is difficult.

No worries, glad you are up and running now! I hope I didn’t come across as being frustrated with my rapid fire questions. I’m glad you asked and got things working!