Web Interface Doesn't Load if I Have Lights Connected

Hello. I’m running a PB3/SB1 combo. I have a 5V power supply connected to the terminals. When I power on the PSU, the lights come on and display a pattern fine, but the webpage won’t load. If I disconnect the lights and connect the 5V directly to the terminals, then the website loads fine. I am able to get to the recovery page and this is what I see:

  • Name: Pixelblaze_3C17B5
  • Pattern: edgeburst
  • Version: 3.30
  • Expansion: SB1.0
  • Pixels: 527
  • Storage: 2039K free

It does take a long time to load > 1m. Could the voltage be too low? It seems to be getting 5V if I measure from the terminals. I tried forcing an update to repair, but it never seems to complete.

This doesn’t sound like a repair issue. I wouldn’t go down that route unless there’s evidence the main app is damaged. For now let’s assume it’s intact.

It sounds like a power related Wi-Fi issue. Could also be something near the antenna or otherwise blocking the Wi-Fi signal.

To isolate the issue, disconnect and remove it and power via usb. If everything comes up ok, then you know the Pb is ok.

I’m guessing the power supply power isn’t good, and the extra load of the LEDs makes it go from bad to worse.

I’m continuing to have problems with the web interface. I disconnected my external power supply and the lights and now am just powering the board using usb. The first time I have it scan and connect to wifi, it works great. If I unplug the usb and put it back, the website will load very slowly with the websocket connection disconnecting and reconnecting often. I will get the message about the previews not loading. I’m using it in the same room as the router and the dbm is -41 which seems ok. Not sure what the problem could be.

I’ve tried Chrome and Safari

Hi @jason, is your network 5GHz or 2.4GHz? I’ve had issues with the combo network, where it’ll connect but then the router pushes it up to 5GHz and then you can’t access it.

It definitely is a power related WiFi issue. Your power supply isn’t able to keep up with the extra draw, or is becoming noisy/dirty. Bad power will wreck WiFi. You can try adding capacitors, which can help smooth it out, or swap out the supply.

You could also power the PB separately, from a good USB power source, and drive the LEDs from your current power supply. If you go that route, be sure to connect the negative (GND) side between the LEDs and Pixelblaze or the data signal to the LEDs will get garbled.

My router has both. I have a ton of smart home stuff which mostly uses 2.4 and it mostly is fine. I know a couple of these have esp32s in them

To be clear, I disconnected the 5v power supply completely and just powered it off usb. The first time after joining the network it runs fine but if I unplug the usb and plug it back in to reboot it I start getting dropouts

So you are running it from USB, without LEDs? Just to confirm that it’s connecting to your local WiFi in Client mode, not creating a network using AP mode?

AP and setup mode will randomly choose a WiFi channel. That might sometimes landing on a very busy channel. If so, power cycling a few times might help (or make it worse, roll of the dice), though it would be temporary until the next reboot.

In client mode, it connects to your router’s channel and that wouldn’t change between power cycles.

When you scan networks (either in setup mode or on the WiFi tab thereafter) what kind of signal levels are you seeing for your router in the list?

If it doesn’t turn out to be a signal problem of some sort, here are some additional wifi things to try:

  • If your 2.4 and 5ghz networks have the same SSID, try temporarily disabling or renaming the 5ghz net and see if that helps. Devices vary greatly in their ability to handle the “two networks with the same name” thing.

  • What kind of router is it? If it’s got advanced configuration options (cisco, ubiquiti, microtik, dd-wrt, pfsense, etc.) check to be sure that Frame Burst/packet bursting feature is disabled on the 2.4ghz net. (Seriously - This one caused me several days of head scratching frustration at one point – turned it on accidentally while setting up a new AP, and suddenly Pixelblazes wouldn’t connect, or I’d spend a whole lot of time watching the spinning cube.)

Thanks. I ended up just getting a new router and this one seems to connect a lot more reliably.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.