WS2811 LED’s not working properly

I have a project I’m working on with WS2811 LED’s and I’m using my Pixelblaze v3. When I go into setting for Neopixel…it won’t let me change the clock speed (I have three v3 Pixelblaze’s and all three are the same).

The string of LED’s act like the clock speed is too fast and just stays mostly white and blinky.

I’ve tried running all the other options (dot star, ect) and nada.

Does V3 only allow one clock speed for Neopixel?

Any suggestions?

This is the LED’s I’m working with ALITOVE WS2811 12mm Diffused Digital RGB LED Pixel Light Individually Addressable Round LED Pixels Module IP68 Waterproof DC 5V 50pcs/Set

Hi @Karldettmann ,
I have LED strings just like that that work, and the timing used should work on just about everything that runs at 800KHz. Timing was adjustable in V2, but this caused problems.

Are you using a single 5V supply for both, or separate power supplies? One common issue is not having GND connected between the LEDs and Pixelblaze, just data won’t do it.

Are your LEDs very far from Pixeblaze? How do you have them connected?

Yup…that fixed it. Doh! Sooooo easy

1 Like