Zero output from PixelBlaze

Everything was working fine then all of a sudden the pixel blaze stopped all outputs.

I am able to connect via AP. i see FPS sitting at above 760. I am getting 5v at the led strip. The pixel blaze and led are getting powered from the same source.

I connect an SP002E controller and the strip lights right up.

What can I do?

I connected the PixelBlaze power via USB and the strips lights up but its very bright, and very white :slight_smile:

When I attempt to modify a pattern the software says generating but there is NO preview on the PC, and no output.

Currently the strip is connected to the connector riser.

Is it to a Pixelblaze or an output expander? WS2812? Check that the LED type is set up right. A bunch of white LEDs usually happens when the type is set to APA102 and they are WS2812 LEDs.

Are you powering from a battery? If it gets low the PB will probably still work at lower voltages than the LED ICs logic will

Yes from the expander. The settings were set to output expander and the proper count of LEDs were set. it just stopped working. The LEDs turned white after I bypassed the output and just connected straight to the riser.

They are being powered by an external battery, but using the usb 5v output. The battery was and is sitting at 12v.

When I connected them to a pc usb output is when I was able to get the LEDs to at least light up.

Here are some images

The data lines needs a shared ground reference, try running GND from the output expander to the LEDs. In the photo I can see that both LEDs and Pixelblaze appear to be powered, but the wires are going out of frame, so I can’t tell if they are from the same supply, that GND is connected together.

Hi Ben, thank you for the reply.

The LEDs and the PixelBlaze all share the same ground. The GND is out of frame but its only going to the external battery pack.

I will use the ground specifically from the expander to the LEDs and report back. Previously the LEDs were using the ground straight from the battery.

Can you post your settings? Rereading your post, the missing preview is strange.

here is

the settings page

Here is the pattern program page, notice no preview.

It’s hard to tell whats going on exactly. Your pattern might be suspect, though it looks mostly like KITT, its hard to diff it from a screen shot. Have you tried other patterns? What happens if you click “New Pattern” to load a basic rainbow pattern?

On the top right of the nav bar are various stats, what do they show?

What happens if you give every channel 20 pixels and hit Auto index?

Hi Ben:
At this point I firmly believe I may have a hardware issue, reason is at the slightest movement the controller is shutting off and back on. Let me answer your questions:
The pattern used is a modified version of KITT, this problem is consistent with any pattern.

When I click new pattern, the problem remains.
Here is the settings screens as of right now, I followed your instructions:

Here is the edit screen with the top right information:

Perhaps you do have a hardware issue, but you should see preview pixels even if something is wrong with the LEDs or output expander. The preview only relies on Pixelblaze and a connection. With a black preview, good hardware won’t display anything either.

Would you also try changing the led type to No LEDs? Make sure Pixels has some value.

Ooh, another thing to check, do you have the auto off timer enabled?

Here is the settings page with no pixels etc.

Still no output.

What can cause the preview to go totally black or totally inop?

The pattern firstly, then brightness and limit brightness settings are taken into account. The auto off timer works by setting brightness to zero internally.

Test with the “new pattern” rainbow, since that will be full brightness and obvious when things start working. Try changing both brightness settings, set the slider all the way to the right, and set limit brightness to 99 (since it’s already 100). Check, then uncheck the Enable for the timer. Changing settings sends the new value, in case the value it has is different than in the UI for some reason.

If you have a pixel map, try removing it (empty the text area), and click save.

Keep an eye on the top right, and make sure it doesn’t flip from Connected to Disconnected. If Pixelblaze resets for some reason (like power issues) the currently running program is lost, and the last used program is loaded which might be black or have an error. Network issues can also prevent the preview from updating, but usually that would just look choppy, not black.

Hi Ben:
attached is a screen capture of the pattern page. At least it is generating a pattern, but sadly still no output even after connecting various known good LEDs strips. The pixel is still turning off at the slightest movement.

While the pattern was generating I did pay attention to see if it disconnected, but I never noticed it disco or any major changes. What I do notice is when I grab the pixelblaze in my hand and just move it, all the LEDs on the pcbs go off, then back on except the blue led. The blue only turns on after I reconnect. All solder points on the riser are solid, and the 5vdc and gnd wires are properly screwed in. This happens even when using a usb connection to power the pixelblaze.

I just noticed while I typed this reply with the controller sitting at idle, I just grabbed it and it seems substantially hot; more so than ever before.

Hi @Wildersrobles,
What changed that caused the preview to start showing up?

Now that you have something there, we can move back to hardware. You’d have to switch LED type back to output expander.

If things are changing when you touch or pick it up, you probably have a wiring/soldering problem. I know you’ve already checked those, but unless you are hitting it with an electrostatic discharge, something is loose and either disconnecting or shorting. Since things are getting hot, I’d check for shorts.

Shorting 5v to parts of Pixelblaze or electrostatic discharge could cause all kinds of bad things to happen. If anything is hot, remove power, let it cool, try to isolate which part or action triggers it.

In one of your photos you had the LEDs connected to Pixelblaze’s out put on the screw terminal. When LED type is set to output expander, it won’t work right with LEDs, but you can switch the LED type to WS2812. If the LEDs work, then at least you know that Pixelblaze is working and sending out data.

this is what I did to generate a new pattern

I have done this on numerous occasions and the problem remains. I have switched to the output expander, changed the settings, placed back to the screw terminal and the problems remain.

At this point all l can I do is start dismantling the controller to isolate components.

ok just for record keeping
the sensor and the expander boards have been eliminated and the problem remains.
the led strip is confirmed to work but with a different controller - this was done to eliminate the LED strip as faulty.
Power sources have been changed between external 5vdc and usb sources (connectors and screw terminal) - problem remains

For anyone else following along, we took this offline. Working through various hardware troubleshooting steps.

The blue LED on the PB module going out when it was touched was an interesting clue, so we’re looking at tracing GP2.