Doesn't remember WiFi settings after a power cycle

I have a v3 board that will not remember it’s WiFi settings after a power cycle (tried multiple times, associates to the same SSID as all the others, and can hit the web interface on the network, but after a power cycle it goes back to broadcasting it’s own Pixelblaze… SSID. Also after setting the WiFi, an SSID with ? + other random/bad characters is being broadcasted for while.

The v3 board is new out of a package today, after soldering on the screw strip.

Hold the button until it goes in to setup mode. This method of putting the device into setup mode will now (since 3.17) also clear the non-volatile memory area where wifi settings are stored and should resolve any data corruption there.

The frameworks and OS store WiFi settings, as well as a few other things in a special section of flash memory in a key-value database. I suspect these issues are caused by data corruption in that database, and I suspect that is what causes both wifi amnesia and random SSIDs.

Tried the hold button down until it goes back to setup/broadcasting it’s own SSID. Same problem, after configuring WiFi connection it does connect, but after power is disconnected and applied it’s back in setup mode.

After applying power to that board I always get the following behavior from the onboard LED…
LED bright, off, LED bright flash 3x, off, LED bright steady

Whereas on other v3 boards that are associating to an AP without issue I see…
LED bright, off, LED dim steady

Measured resistance between GND and BTN on this problem board (thinking maybe the button is mashed internally) I get 1.73m ohm to 2.5m ohm when not pressed, 0.5ohm when pressed … so I don’t think that’s it???

Yes, that 3 quick flash LED sequence at startup means Setup mode. If you press the button, it should cycle through patterns, and if holding it did put it in setup mode, then physically the button is OK.

A snag/bug - holding the button while it’s already in setup mode doesn’t work and won’t clear the nonvolatile memory. It will turn the LED solid on, but no quick flashing. This is a bug :man_facepalming:sorry! To work around it configure it in client or AP mode and then hold the button.

Look for this sequence when entering SETUP mode: Long BLIiIINK, flash+flash+flash, resets, BLINK, flash+flash+flash, pause, solid dim.

Another possible snag, when you connect to a wifi network in setup mode it can take several seconds for it to fully connect, and it will only save the settings once it has successfully connected. After connecting, a few seconds later it will drop its setup AP network. I would wait for the setup network to go away before disconnecting power. If you remove power immediately after configuring it, it might not have saved yet.

Assuming that wasn’t it…

If you put it in AP mode, does that stick? I’m wondering if it’s an interaction with a router. Another thing to try if you have a 2nd PB handy, put the 2nd PB in AP mode and connect the problem one as a client to it. Does it remember wifi if connected to this different network? If it remembers those settings, perhaps switching it back to your wifi might work now that settings for client + AP have been written.

In the other cases where folks reported this I replaced their PB and the new unit worked for them. But when I got the return I could not reproduce the issue here. Putting it into setup mode and connecting it to my wifi worked fine and was remembered.

I know thats a bit of headache to go through, I’m trying to narrow down where the problem might be.

Did any of that trouble shooting work for you? I tried everything listed above, and I’m having the exact same problem as well. Resets every time power is cycled