Firestorm PB V3 setup assistance

Hello, I believe i have successfully setup firestorm on my PC, but cannot get the Web UI to connect. Issues first with nodejs, but after downreving to version 16.18.0, all appeared to go smooth from there. I have tried on both port 80 and 3000. It appears to find my pixelblaze, confirms the correct IP address and i can also get a response typing discover in the API, but when i try my browser, cannot get firestorm page to load. What am I missing? any advice is appreciated. I might add, this is my first pixelblaze. Currently have it automated through my Hubitat as well. Its working great standalone, but struggling with Firestorm. Thanks in advance. Edit - had more images, but limited to 1 since i’m a noob. will try to add more later if needed.

second pic of webpage attempt from local computer. tried with both ports 80 and 3000. both successfully set and verified working using netstat -a. can see port open and close as i turn on and off firestorm, but no access to UI via web page. what am i missing?

Use (localhost) instead of (“I am listening on every IP address on this computer”)

1 Like

You the man! that worked, thank you.

Oh good, a existing thread! So I’ve done the install, it’s currently listening on 1889
and says connected. and sending.

Not getting the UI to come up. Tried and just gets a basic page unavailable just shows up “Cannot GET /” in the top left corner.

I should say that I used Glitches installation from this thread to do a install (before I realized it was unnecessary steps)

So is there anything I could possibly be forgetting? I did a uninstall and fresh Firestorm install and still same result.

Are you connecting from the same machine? If so, then will work, otherwise you need to use the IP of the machine running Firestorm.

1 Like

Still getting the “Cannot GET /” error with and with the machines actual IP address

Since this is a brand “new” (refurbished) laptop I’m just gonna go for factory reset and assume I screwed up with the extra steps in the installation for the moment and try again.

Also I’m having issues with firestorm detecting any of the 4 PBs in AP mode but lemme go do a factory reboot, reinstall and see if that helps anything.

So it’s the same machine hosting Firestorm? Can you try another port?

Firestorm won’t work if all of the PBs are in AP mode. It has to be on the same network at them.

So! I did another machine wipe, followed everything step by step and noticed this happened when I tried Yarn Build

So there’s obviously some sort of error happening during the Yarn build. I don’t really know why the install is failing but here’s the relevant info.

edit Figured out why the port wasn’t setting. Still unable to figure out why build keeps failing. Have tried on 2 different PCs


So I installed a older version of Node that’s currently offered than 18.12.1 as the default download on the site and Firestorm loaded right up. I think something in the newest version of Node is conflicting with Firestorm.

edit After re-reading the thread more thoroughly, I see that was already mentioned up there. I will find a way to make this harder on myself every time.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.