PB3 will not connect to Unsecure WiFi

I’m currently using a public WiFi connection and my PB3 will not connect. When searching for networks, it shows the available network. But, it says the network is secure when it is not. The “Lock” displays next to the network name and requires a password to connect even though there’s no password on the network.

I’m running v3.16 firmware.

Not related to the WiFi issue, but here’s a little story about my experience with this PB3:

This is my first time getting into PB, but I’m not new to LEDs at all. I do extreme Christmas lighting like you see on TV. The PB3 arrived yesterday and I soldered the power terminals on the board. Powered it up and connected to the AP it creates. Brand new, out of the bag, I couldn’t connect to the web interface. I didn’t even get the loading screen. I could ping the device, so I knew it was responsive. After a bit of research, I found this to be issues with devices that were working and then the interface would stop working… I wasn’t able to find new ones that didn’t work. So, I kept reading and found something that said I went here and the page loaded. Then I was off to find firmware (Also not an easy task for a new person. There should be a link in the menu of their website). Found the firmware and uploaded it. After the update, I’m in business! Woot Woot! After connecting some LEDs and playing with the interface a while, it became VERY slow and unresponsive. Rebooting the PB3 solved this issue for a few minutes, but it would always come back again. After more reading, there are several reasons why this might happen. The main reason I see is lack of memory, but this is claimed to be fixed with the new firmware and PB3. Another reason I found was lack of power. I was using my PC USB port, but was only running an 8x8 pixel board set at 5% max light brightness. I doubt power is the issue, but I’ve switched to a 2A power supply just in case. I haven’t tested yet, but I’ll report back results later if needed.

Overall, the concept of the product is outstanding and it appears to work… mostly. Maybe I just got a bad one?


Update the firmware, I believe the fix for unsecured wifi was in 3.17?

Yes, you’ll have to connect to a wifi with a password to do so. I run my wifi open too, and this was an issue and I had to add a password to a router (I use a few), in order to update them.

Trying to update has caused a new issue. I updated again using the link http://app.bhencke.com/pbupdates/latest.zip (which should be 3.17… but, it’s 3.16 which apparently has a bug listed here: Doesn't remember WiFi settings after a power cycle - #5 by Illuminationspecs ).

This time when I updated, the WiFi selection options don’t appear anywhere. So, I pressed and held the WiFi button for 5 seconds. When I reload it takes me here: BUT… it’s not the WiFi setup page. It’s the PB Web interface with all the patterns and such on it. If I hold the button again, the LED comes on solid (meaning I’m already in setup mode). Any page I go to takes me to the same screen. I can’t even get to anymore. It takes me to the WiFi
page, but loads the whole interface.

I think the solution will be for me to upload the update manually by either uploading the most recent version 3.17 or using an older version before 3.16. Problem is… where do I get these files? I’m using Windows, so a Batch file would be easiest.

I think I know what’s going on. It took me a while. I think you fell into an unintentional trap created here with older posts about Pixelblaze V2 giving advice, and applying it to your V3.

That latest.zip URL is not for use with version 3 and above. That is only if you have a very old version 2 that pre-dates automatic update and need to bring it up to the point where automatic updates can start working, in V2 only. V3 has always had the new update system.

I think that if you ran that old version 2 update on a version 3 that it may overwrite the web application component with the old version from V2. The firmware that runs on the chip would not have reverted (otherwise it would have been bricked).

If you are running an older web application against version 3, that would explain why the setup page isn’t working. The web application detects that URL and hides most of the interface except for the Wi-Fi setup tab. But that hasn’t happened and you don’t have Wi-Fi tab which was also added in version 3. In V2 the setup page wasn’t part of the web application.

Unfortunately /update wasn’t available when in setup mode on older versions of V3, it is in v3.17 and up.

The fix

There’s 2 steps well have to take to fix things. First, we need to get it into AP mode. We want AP (since your Wi-Fi network doesn’t have a password).

You’ll need to download the curl utility and run this on the command line:

curl -i -d "mode=AP&ssid=pbrecovery&passphrase=password&discover=true" -X POST

Now you should be able to connect to it (the password is password), and get to the /update URL again.

Next we need to manually update the firmware using a version 3 firmware update file.

This is the 3.18 update file. Installing this will fix the weirdness with your web application, and also update it to allow passwordless Wi-Fi.

For V3 standard
For V3 Pico

Let me know if you get stuck anywhere on this. If you do run into trouble I think I can put together a recovery tool for you tomorrow.

It’s usually quite easy to set up and update, and I’m sorry you got some incompatible advice from old forum posts. If I might ask when and where did you buy your Pixelblaze? It sounds like you started off with an older firmware.

1 Like

@wizard Thanks for the correct update file! Once I was out of setup mode and had the correct file, the update to 3.18 was simple. Now I’m back to the issue of not being able to connect to the WiFi because it says it’s secure when it’s not.

Submit is still disabled because I’m not inputting a password.

I purchased my PB3 (and expansion board/sensor board/8x8 grid pixels) last week from your store in Tindie: https://www.tindie.com/products/electromage/pixelblaze-v3-standard-wifi-led-controller/

The controller arrived (almost) DOA. I was able to connect to the WiFi from the controller. But, when i went to the browser responded with Page Not Found. That’s when I hit your site and the forums and found the update (although, it was unknowingly for V2).


  • Add the firmware update files to your site somewhere easy to find. Some users may want to run older firmware. And some, like me, could resolve this issue quickly on their own.

  • Sort the forms or add Tags for V2 and V3 posts. This may or may not be possible and could be a lot of work. Community leaders could tag threads with V2 or V3 markers. This would make it easier for users to navigate to information related to their needs. (maybe this is done already and I’m just missing it)

Once again, thanks for the help. It’s always nice to see a developer active in their projects. :slight_smile:


1 Like

I see the problem with the disabled Submit button and lock icon now. As a workaround: enter anything in the password field and delete it, the submit button should enable.

Glad its repaired! And thanks for the suggestion! Forum tags were disabled by default, and I’ve since enabled them. Will poke around a bit more and see how I can apply these. I may go through and archive old posts or one-off posts with potentially dangerous advice.

Do you by chance run Windows and have a wired internet connection along with WiFi used to set up the PB? As @haro found out through some exhaustive troubleshooting (thanks!), it seems that particular combination causes problems with the capture portal redirects, but going directly to can work. Using a phone/tablet for setup can also work around the problem.

Excellent! Hitting the space bar 8 times and then deleting everything worked. I updated the WiFi settings and was impressed how quickly the Pixelblaze Discovery Service worked. It discovered the device faster than I could google and click the link for the discovery service.

I do run Windows. The laptop I’m using is connected VIA WiFi only. I understand the issue you’re talking about. This issue will sometimes also affect cell phones (and tablets with SIM data). If the WiFi doesn’t have internet, it will sometimes automatically “Fail Over” to the connection that does. Thus changing your IP address and making the PB impossible to connect to.

Another issue has arrived that I’ve seen around the forms. After the update to 3.18, but before the WiFi settings change… The web interface was not accessible. The loading screen came up and the 3D box just spun in circles. (A reboot brought the interface back online) I’m letting the PB just sit at idle with a sequence running to see if and how long it takes before the interface becomes unresponsive again. If it does become unresponsive again, is there anything you’d like me to test before rebooting the device?

I have 564k memory free with all the default patterns and two or three extras.

If you can keep the browser dev console up, it might print out some useful error messages to the console there.

WiFi signal strength can be a significant factor. Make sure you don’t have any metal near the Pixelblaze’s antenna. Try moving things closer together. Long wires from the power supply, noisy power supplies, or grounding issues can also impact WiFi. Adding capacitors close to PB can help in some cases. Sometimes getting a cheap wifi extender can make a huge difference!

The #1 underlying cause for the infinite spinning cube loading screen is when the connection downloading the page is dropped. On Chrome the console will emit an error message with net::ERR_CONTENT_LENGTH_MISMATCH. Reloading the page is usually enough to get it back. However, sometimes loading the page just takes a while especially when wifi is iffy, so I’d give it a good handful of seconds before assuming it broke.

The #2 cause is when there’s a problem connecting to the websocket. It will retry after some seconds though. If that persists, a reboot usually clears it up. Sometimes the websocket server networking gets in a bad state (reason unknown), but this is less common. On Chrome the console will say something about websocket connection errors.

I wouldn’t assume the web app has been corrupted without further troubleshooting (don’t follow instructions in those other threads).

Once the page is loaded, the websocket connection should remain connected. However, WiFi hiccups do occur and can stall things, but generally things should recover without issue. If the connection is stalled for too long, it will time out and reconnect. The connectedness status on the top right of the page should change if this happens.

The storage space free doesn’t impact that much at all - only really comes in to play when updating firmware or saving patterns, and I wouldn’t worry about it too much at this point. Since 3.18 the update process no longer requires having heaps of free space. However, if you did get it nearly full, saving patterns could take longer as it has to shuffle things on flash to make room.

Good info to know… Thanks!

I didn’t pay attention to the error (if any) given in the browsers. I attempted to load the interface in FF and IE on my laptop and only got the loading page. I also tried loading it on my phone, but only got the loading screen. This is when I rebooted the PB. I did wait quite a while before rebooting, just in case it was being slow.

So far, it’s been idle for about an hour with no issues. :slight_smile: I’ll keep an eye out for errors and let you know if something goes wrong.

Thanks again for all the help. :+1:


1 Like


I let the PB run overnight and in the morning, the patter was still running. I left the GUI open, but somewhere throughout the night, my computer rebooted. Upon rebooting the computer, I connected to the PB and opened the GUI in my browser. It loaded properly and everything seemed fined except…

As soon as the GUI loaded, the pattern one the LEDs froze. They stayed lit, but were no longer animated as seen below.

In the browser, there’s an error that says “No Valid Render Function Found!” (See below) It also shows “honeycomb 2D/3D” as what’s running, but I don’t think that’s what was running all night. I think it was running CubeFire 3D.

It’s not a major issue and I’ll test it again tomorrow morning (or as I login later today). Clicking on a new sequence started the animations again. (I did select a pixel mapper before selecting a new pattern, but nothing happened until I loaded a new pattern.)

Logging into the PB3 shouldn’t stop a pattern that’s active. I don’t think? And like I said… this isn’t and issue I can’t live with. Just a small, unexpected error. :slight_smile:

Did you save your pixel map? If you power it off, and back on, do you get the same “no valid render” error?

I actually never edited the per-installed pixel maps. I just loaded “Matrix” and started the sequence last night. Since I didn’t edit the basic map, I didn’t see a reason to “save”.

I haven’t played with maps yet, so I’m sure there’s a lot I don’t yet understand.

Ah, if you load “Matrix” and don’t hit save, it doesn’t actually save it.
Nothing is installed ‘by default’, but the examples are loaded if you select them.

Okay. I was curious is there was code to “select” the type of map you wanted to use automatically. But, I guess that isn’t really needed since most people probably aren’t changing the LEDs and layout(map) that often.

Thanks for the info. :slightly_smiling_face:

2 posts were split to a new topic: Stuck on Spinning cube loading screen