Pixelblaze v3 won't work with some strips that v2 did work with

I have a bunch of strips that seemingly no longer work with the v3 board, cause I can’t select the right data timing, only option is 800. Whereas they did work with the v2 board, which offered allot more timing options.
Perhaps I am doing something wrong?

Nope, we’ve discussed before that v3 lacks the timing options of v2. That’s one of a handful of things v2 beats v3 on, input pins I think is the other major one.

Is that something that just hasn’t been added yet but will later?
Is that some conscious decision based on timing not being needed or not possible for some reason?

It has to do with drivers and code work mostly, and when I get some time I can rework things and add variable timing.

When making the V3, there were surprisingly no working WS2812 drivers for the esp32 that wouldn’t flicker in various conditions like reading flash and sending data out wifi, which PB does rather frequently. Every LED library out there had issues, even fastLED.

I ended up forking fastLED’s driver from Sam Guyer’s in-progress branch, and with a few modifications I got it working.

That code doesn’t lend itself to dynamic timing, but could be made to with a bit of rework.

@jpm , how far away are your LEDs from your PB? Which LEDs, do you have a make/model?

The timing used should be good, but with long wires for the data line and/or voltage issues it can get misinterpreted. The timing setting was a handy way to adjust for that, but there are possibly some ways to clean up the signal electrically.


I have tried various 5v WS281x strips today…
Some are Amazon, some Costco, some SuperBrightLEDs, some LEDENET
on a v2 board they work at 444ns through 286ns when connected very short to the PB

on a v3 board they do not work at all, or always stay white

Hi @jpm,
That doesn’t sound right. I wonder if there’s a hardware or wiring issue perhaps? Can you take some close up photos of the top of the board and solder connections, we can help remote-troubleshoot.

I also want to clarify that while the timing isn’t variable, I don’t know of any WS2812 compatibles that don’t/won’t work with V3. I can imagine in some less than ideal scenarios where variable timing would help with long distance or voltage issues (edge cases, if you will, pun intended). That doesn’t seem to be the case here and since you’ve tried multiple kinds of known-working LEDs my guess is that it isn’t related to timing at all.

OK, did a bunch of testing today. Turns out, yes, the v3 board can drive all the various strips I had at the fixed speed setting - when the cable run is 2" away from the board - will test a longer cable run tomorrow.

Turns out that particular Pixelblaze v3 board I was testing with had some strange error, the dimmer slider showed 50% but was infact not working. Ended up adjusting the max brightness from 100 to 1, then adjusting the slider, then setting max brightness to 100 again, then adjusting the slider, and it started working.

[ NOTE: I moved the rest of this post to new topics [1] and [2] - @wizard ]

Hi @jpm,
I’m glad your V3 is working with the LEDs. What kind of cable length did you have before where nothing was working? Can you rule out soldering/connection issues?

You have quite a few PBs, going back years! I definitely want to help you get all of them back in service. For the purposes of keeping the forum topics organized, so that others can find information if they have similar problems, I’d like to keep topics focused to one issue. I’ll split out the wifi issue, and send you an email about the v2.