Sensor board not working

Hi there, I have a pixelblaze v2.5 with a sensor board soldered to the underside of the pixelblaze with the correct orientation. I have been unable to get the sensorboard to respond at all.
I tried to test different patterns, but none seem to have been responding as anticipated. When I downloaded various sensor-dependent .epe files from the patterns database and then uploaded them to the pixelblaze, it had code errors and resulted in an all black preview. I tried playing audio to be picked up by the mic and also tried running audio into the 3.5 mm jack and wasn’t getting any response. The non-sensor board dependent patterns all worked fine and ran successfully for hours on end, it was only patterns involving the sensor board that exhibited issues.

Now though, after being unable to get the sensor boar to respond, the pixelblaze board seems to have now failed, as the blue led goes out momentarily every few seconds, which seems to indicate that it is power cycling. I tried plugging it into different 5v sources via microUSB, all with the same result. I can no longer connect to it via wifi as the network no longer shows up. Can you think of what could have caused this result?

Hey DRC -

With the code errors on the sensor dependent patterns, it sounds to me like the Pixelblaze couldn’t read the sensor board’s serial data. One way to check would be to look for a “SB1.0” in the top right of the Pixelblaze web interface’s menu bar. Since you can’t access it now, that’s not very helpful.

Two things:

Could you post a picture of your soldered connections just so we can verify the pins?

And second, try holding the button for 3.5 seconds to reset and re-configuring the WiFi; Given that you had some time under these soldered connections where the web interface was at least working, I’m wondering if a repeated fault caused it to reboot in WiFi setup mode. Maybe have a look through the WiFi SSIDs visible from your laptop and see if you now have a Pixelblaze_XXXXXX pen network visible again.

If it won’t let you, I’ll let Wizard weigh in, but it might be time to break out the solder sucker. I worry your GP0 or RST pin might be grounded.

Hi @Drc3p0,
Can you send a photo of how it’s attached? If you haven’t tried disconnecting LEDs yet, try doing that and then powering via USB. Often USB can’t provide enough power for many LEDs.

I got photos of the solder connections today, and cleaned off the flux to get a clearer picture for you all. In doing so, I noticed that the 3.3v trace appeared to be broken. A continuity test confirmed this, which means the sensor board was not getting the 3.3v it needed for power. I followed the trace back to the outer pad of R4 and ran a jumper from there to the 3.3v pinout and confirmed it was now receiving 3.3v voltage to the sensor board. I disconnected the LEDs (which had previously been running for hours with the pixelbalze with no issues). With 5v power connected, I held a jumper to GP0 and GND for several seconds to try and reset the wifi. No change to the board behavior, where the blue LED is turning off briefly every 8 seconds or so… The wifi signal can no longer be found, and only the first LED in the strip was lighting up and changing color in sync with the blue LED power cycling (can’t remember the last code I uploaded before losing signal).

When i had it connected to wifi before the wifi signal went out, it did not list the sensor board on the browser interface.

I am guessing that by trying to run it without the right power connection, it slowly burnt something out? No idea why the 3.3v trace was cut, could have easily been an error on my part.

Pictures of the solder connections, which shows the cut 3.3v trace:
135365839_843724526474438_4759204534209598456_n 134081642_307670877321792_1726942850840744459_n

And pics of the jumper I added to bypass the cut trace:

Hi @Drc3p0,
This is an older V2, right? Do you happen to know which version of firmware is installed?

There was a bug in early V2 firmwares that could cause a reboot loop. v2.6 and v2.7 could enter a reboot loop when a sensor board was connected. I had sent out emails to any customers of both at the time (June 2018), but if your sensor board was a recent purchase and your PB version is old enough, you might have been bit by this issue and missed the email that I’d sent.

The work-around is to disconnect the SB or short TX to ground until you get the firmware updated. If that brings Pixelblaze back, then you definitely need the update.

1 Like

Hi @Drc3p0,
Please let me know if any of that helps, or if it doesn’t!