Unable to connect to PixelBlaze after discovery

I’ve been trying all morning to “connect” my PB’s to this site for some friendly code manipulation however none of my PB’s can be found! Setup page seems to work and after it allows me to configure the WiFi network this is where things fail. PixelBlaze can’t be found after Discovery. What’s going on? Is this a problem on your end?

Is this on a computer, or a phone?

The discovery service relies on the external IP address you use, so if you have a phone that isn’t using your wifi and instead using the cell carrier internet, it won’t show you anything.

I’m using an iMac. 2.4 KHz (or is it MHz)?

Just want to make sure I have this right. Here is what you did or tried to do:

  1. Plug in the Pixel Blaze, connect to its WiFi network

  2. Select “Client Mode” from the drop-down menu

  3. Select your WiFi network and enter your password

  4. Click Submit, and get a message about a successful connection

  5. Reconnect to your own WiFi network, and go to http://discover.electromage.com/

  6. See your Pixel Blaze listed with an IP address. Something like this:
    image

  7. Click the link to your Pixel Blaze on the page, which then tries to connect

  8. Successfully load the Pixel Blaze interface.

Your problem is between step 7 and 8, correct? You click the link, and get something like this?

If the discovery page can see your Pixel Blaze, but the IP address listed doesn’t take you to the interface for your Pixel Blaze, then the issue is almost certainly that your device is not on the same network as the Pixel Blaze, or the network is set up in a way that would not allow traffic between the two.

2 Likes

It looks like I have a bricked PixelBlaze. Bummer. Why isn’t there a reset button (software or hardware) available to use. Prior to being stuck on a very still pattern, everything seemed to work just fine until this morning when I wanted to see if my previous Playlist still applied. It didn’t and I got random patterns instead of my Playlist even though it said it was playing the Playlist. So I tried restarting PB (holding down the button for 7 to 10 seconds). This doesn’t work anymore. Yes I can sometimes get the rotating box and then get to the Pattern screen but PB doesn’t respond. Is it bricked?

Okay it’s been almost 2 hours and I restarted my PB & display. Unmoving (stuck) pattern and even though Discovery says it’s here, no dice. Was working fine before I shut it down.

I am trying to RESET my PB which is stuck in Fail-Safe mode. It’s getting clean power externally but has a dickens of a time having this interface recognize it and when it does I set up th SETTINGS, MAPPER then goto the Patterns but none work as it’s stuck on a pattern I don’t recognize and full brightness, which I can’t control. Is there a ‘button’ or script I can copy while in the EDIT mode and execute to RESET my PixelBlaze? I’ve seen this while searching for a fix. “Fix discovery flag setting in the recovery.html app”
What does this mean? And can I use it? If so, how do I use it?
Thank you all

You say it is getting clean power, how are you checking that?

If your PB is showing the fail-safe warnings, something is wrong. The most common cause is power related. In rare cases a corrupt file or pattern bug could cause a crash/restart, and after a few of those Pixelblaze will start going in to fail-safe mode and IGNORING some of your configuration. If it’s power/hardware related, there isn’t much that you can do it fix it in the interface (except perhaps drop brightness way way down to unburden a weak power supply).

The fail-safe happens progressively the more it restarts until it goes all the way back in to setup mode. The fail-safes are non-permanent unless you use the interface (such as to reconfigure it, or pick a different patter). Powering it off and on again will restore your original settings unless you changed something. If the cause of the resets is config/pattern related, then re-configuring it with the interface to a good configuration would cause your reset problem would go away.

You can’t properly use a Pixelblaze if it is resetting constantly

If it is constantly resetting and triggering fail-safe modes, you must find the cause of the resets before you try to use it normally. The fail-safe protections will keep a bad configuration or pattern from being a permanent & unrecoverable problem, but it won’t fix the problem.

What is the status LED doing when you apply power? If you can, take a video and post screen shots of your settings and mapper tabs, if you can get in to the interface. Keep an eye on the status LED and the connected state in the UI, find out what actions cause the reset.

If you are connected, you can click on another pattern to switch to it. If that isn’t working, then you either aren’t connected (look at the connected state on the top right), or the pattern you click on has crashed your PB and is the cause if your resets (and thus fail-safe mode).

I use a volt/ohm meter on the power pins and yes, I’m getting 5.24v @5.0amps. When I observe the LED on the PB board it blinks once, three times, rests then continues to repeat the same pattern. Plus the 276 LEDs in my display stay constantly on (I don’t recognize the pattern as there is no pattern). The problem seems to be with the stuck LEDs always on. I can sometimes via the Patterns page get the display to change if I go to EDIT mode and upload a pattern. I cannot select any pattern form the Patterns menu as my mouse cursor fails to select no matter how many times I press. Unable to take any screen shot as I cannot get online.

The controller has restarted from repeated errors and has loaded fail-safe settings. Proceed with caution - using this interface may persist fail-safe settings.

This is abnormal. It should go to a solid dim color and stay put. If it blinks again (with or without 3 flashes) then it is resetting.

If it repeats this pattern a number of times, then goes to solid dim and stays there, then the fail-safe mechanism has temporarily restored stability by skipping whatever is causing the resets. If so, how many reset cycles does it take to become stable from completely powered down until the status stays on a solid dim with no blinking? If it gets to a stable solid dim status LED state, does it stay there or reset eventually? Does it only start resetting if you change something? If so, what?

5.24V is a little high, but shouldn’t be causing a problem. A volt/ohm/multimeter won’t show you if the power is clean or dirty. If there are any high frequency noise elements present or the power drops momentarily, a volt meter won’t show you that.

What state is Pixelblaze in at this point? Does the page show connected, or stalled/disconnected? Did you reload the page? Does it reset when you select a pattern?

I don’t follow, do you mean you can’t get to the page because it’s offline? If you are seeing the message about fail-safe settings or a list of patterns, then you should be able to take a screen shot of the Pixelblaze page / screens.

Okay I have pics for you.




You can see that I’m connected but am unable to select any pattern. The LED on PB is a steady orange.
I can manually download a pattern when in EDIT mode and the pattern works as expected.

Did you power it off, then on? Did it do any of the reset cycle stuff? Did reload the page, or have it already loaded? Did you get a message about fail-safes?

I can see it was trying to run a pattern that didn’t match the installed map (or there was no map). Did you load 3D only patterns on to this PB?

If clicking on a pattern doesn’t work, does export, edit, or clone work?

What happens if you press the button briefly on PB, does it switch to a pattern? Does the UI reflect that as well?

Did you power it off, then on? Yes. Unplugged completely at least 3 times as I checked and recheck my wiring, which all worked well before.
Did it do any of the reset cycle stuff? Nope. Blinked once, three times then was steady orange.
Did reload the page, or have it already loaded? Huh? I had to select from WiFi and start all over.
Did you get a message about fail-safes? No messages this time.
I can see it was trying to run a pattern that didn’t match the installed map (or there was no map). Did you load 3D only patterns on to this PB? Yes I did but it also had 2D. It was a sound file which I can’t remember just now but that is when the issues began. All kinds of strange stuff started happening on my display and it didn’t matter what was playing on the playlist.
If clicking on a pattern doesn’t work, does export, edit, or clone work? I go to the Edit tab (upper bar) and so far that’s the only thing that works. I’m not familiar with EXPORT or CLONE. I have chill conefitti running as I downloaded the file but when I unplug my PB then power it back up the same issues persist.
What happens if you press the button briefly on PB, does it switch to a pattern? Nope. Nothing happens.
Does the UI reflect that as well? The UI doesn’t work. My playlist is playing but the LED display only runs chill conefitti and I CANNOT select from the saved patterns list. I can select from the playlist list but it’s not reflected on my display.
Thanks

Do you know why it was in setup mode (flashes 3 times)?

Please describe this in detail, a video would help.

You don’t have a playlist show in the screen shots. Did you create one?

These are buttons in the pattern list. There is: Edit, Clone, Export, and Delete. Export downloads the .epe file, and clone and edit both load the source in the editor and switch to the Edit tab.

Loading files in the editor does not automatically persist them. You have to click save. What exactly happens when you power it off and on again after having configured wifi & LED settings?

Do you have anything soldered to the button or touching it or the solder pads for the button? It sounds like it might be shorted. Pressing the button should switch patterns in any mode unless you have a single item playlist. Can you test the button pads and see if they are shorted only when pressing the button? When powered on, the BTN pad should read 3.3v (via a weak pull up).

? What exactly happens when you power it off and on again after having configured wifi & LED settings?
Blinks once then 3 times and presents itself on my available WiFi list.
? Do you have anything soldered to the button or touching it or the solder pads for the button?
The button tabs are clear, not touching. When I hold down for about 8 seconds then restart happens (one flash, pause, 3 flashes).
I can’t switch patterns because patterns (playlist) won’t load and I can ONLY select one pattern on the sequence page and no more then one pattern. Any other attempt at selection of any other pattern just doesn’t work via mouse press. When I shut down and restart later what I’ve stated at the top of this reply happens again but without the warning Fail-safe message.
As I attempt to work on the Saved Patterns/Playlist page I can add to and delete patterns into the Playlist but Playlist doesn’t work. It looks like its working as the timer slides to the left but nothing is reflected on my display. Just the first/last selection pattern works.

Have you tried this PB with any other leds? Like a string or strip?

Thank you for the suggestion which I did this morning. The “broken” PB seems to be running just fine. I need to check my other display and look for the problem there.

Hi @FredEBear ,
Did the problem go away? Was removing it from the LEDs/enclosure the trick?