V2.24 - Playlist + atan2 fix

Just in time to tinker with before the year’s end, the playlist feature is available on V2.

Plus a quick fix for atan2, now accepts both arguments and handles atan2(0,0) (returning zero).

You should see it available from the settings page as long as you already have v2.18 or higher (otherwise follow this guide)


Forgive me if I’ve missed the point, but is playlist the ability to groups certain patterns together or is it a function within the code?

Would love the ability to group all sound reactive patterns for one playlist and all others as a second playlist

Yep, it’s a UI feature, no code. Right now there’s only one playlist, but it beats none :slight_smile:

Here’s the original V3 announcement w/ demo:

on the latest version but still not seeing this option

That’s odd. It got updated firmware but somehow missed the web page?

Wonder if your browser cached an old version. Try reloading the page or adding ?something or some gibberish after a question mark to the url.

Sorry man I realise it’s Christmas day. Enjoy I’ll pester you in a few days instead :blush:

@wizard I have 2 boards, saw this post and updated both of them and they’re now both broken. They connect to the network, I can connect to them but they do nothing. I’ve restarted both of them, I’ve reloaded the web page and nothing.

@wizard more specifically the dimmer function is not working so when one was updated it was completely dimmed (because the timer function doesn’t work as expected that’s how I have my daughters turn them off) and I cannot un-dim them. My other daughter still had hers on at a minimum brightness so they will work but you cannot change the brightness so they’re constantly on the lowest setting.

Is it just the brightness slider? Does the rest load and work?

UPDATE: There does seem to be an issue with the brightness slider on ios mobile apps taking a look!

I’ve fixed the brightness slider for ios (and gave it some more testing on other browsers as well). If you update to 2.25 you should be good!


Great thanks. This was using Chrome on Android 11. It works now though!

1 Like