What looks like constant reboot on new board

Recently got a pixelblaze and I am trying to connect to it. The board goes into setup mode but it looks like it is rebooting almost instantly. The blue light will blink once quick and then come on for about 30 seconds. It will then go off for about 15 seconds and repeat. I have not been able to get to the start page. Every once in a while I get connected but it always reboots too soon to get to the setup paged. Any ideas on what to try for debugging this behaviour?

Hi @grtyvr,
Oh no! We will definitely get that sorted out.

Here are a few things to try:

  1. Verify power. Disconnect LEDs if connected, and try powering Pixelblaze via USB from a good source, like a computer.
  2. It’s rare, but I’ve had recent reports that some WiFi repeaters will crash Pixelblaze when it is in setup or AP mode. Try taking it to a different location to see if this is the issue. I’ve updated libraries to try to fix this, but don’t have a way to reproduce and test the fix. Unfortunately the new version only shipped very recently, so you might have an older firmware. It’s possible to update the firmware, but it has to be working for that to happen. If thats not feasible, I can ship you a replacement.

I have checked power, with LED’s disconnected. I have powered it from:

  • powered USB Hub
  • the PSU that I use for my raspberry Pi
  • Phone charger wall wart
    and same behavour in all cases.

I have also tried loading the WiFiManager code from your github onto an ESP8266 DevKit V2 board that I have and using the same PSU it works fine with two wireless devices. So, I don’t think it is a WiFi repeater issue (especially since I am not using a repeater :slight_smile: )

Is there a serial console on the Pixelblaze so I can look for errors during boot?

Ah, you must also be posted on Tindie’s site :slight_smile: That certainly does help rule out power!

There is serial output on the expansion header (115200 baud, 8N1). You will probably see it crashing and spitting out a stack trace once it goes into setup mode (and starts WiFiManager).

If it’s not feasible to try it in a different physical location (might be a neighbor or some other WiFi incompatibility on that version) and update the firmware, I’m happy to send you a replacement with new firmware.

Yeup. That’s me.

I will look at the serial output tonight.

<thinks about setting up a faraday cage at home…or just go to a park!>

And now that I think of it someone at the end of the block just installed a mesh WiFi in their house, but that is around 100M away.

So it is rebooting.

wdt reset
load 0x4010f000, len 1384, room 16 
tail 8
chksum 0x2d
csum 0x2d

Now, off to find some WiFifree airspace. wish me luck.

Did not find free airspace, but I did connect to my pixelblaze when away from the house, so it might be the repeater at my neighbours. Bummer. Where can I download the latest firmware image to flash?

@grtyvr I just made a post with update instructions here

How do I update Pixelblaze?

This should get you the latest, and future updates will be much easier!

@wizard i will do that today and report back. Thank you so much for all your help.

1 Like

Success. It looks like it is working. I will find out what WiFi repeater the neighbor is using.

1 Like

Awesome news! Thank you for giving it a try, and thank you for being patient with that ugly bug!

No worries. Now on to playing with it :slight_smile:

1 Like

I have almost the same problem. I just upgraded the PB to v.2.21. Now the amber and blue light on for 10 seconds, then they both go out, the amber light blinks brightly for 1/10 of a second, and then they both go on again, repeating the process. I have reset it multiple times. It used to work, but ever since I’ve tried updating it and also I was trying it with the serial expander board. My PB board is soldered to the audio-add-on board, and it worked before I connected it to the serial expander board and updated the software. I can no longer flash the firmware to it. I’m using a new iMac and Terminal, when I type “sh update.sh” I get a “curl: (28) Connection timed out after 10004 milliseconds” because of the constant reboots. How can I fix this?
Thank you.

Hi @OdorDecoder,
It does sound like a reboot cycle. Is the amber light blinking 3 times, or just once?

Can you try disconnecting LEDs? If its related to the issue grtyvr was having, moving it to a different location might help.

I disconnected the LEDs, only the USB is connected. Nothing has changed, both amber and blue LEDs stay lit for 10 secs, the blue one powers off for a split second, the amber one turn off for a split second then blinks once brightly, and then they both go back on. The off cycle is only about a second between the on cycle of 10 seconds. I can’t establish any communication and I can’t seem to reset it.

Sent a DM. Let’s get that replaced!