Only 1 pixel is lighting up and that's all

Hi everyone, sorry to bother you but I can’t get any sequnces to run. I have 2812 strip wired to the board and when I connect power through USB then the board blue and yellow lights come on and the first pixel on the strip lights. I can get into the web interface but nothing helps. Maybe the pixel strip is bad?! It’s brand new - how can I test it? Thanks in advance.

Hi @Xsonic,
Do you have the data line running go to the data terminal on Pixelblaze? One is clock for apa102 style LEDs and won’t work. The other thing to check is that the led type in the settings tab is changed to ws2812. You can also try different timings, but it should work with the default timing.

Hi, yes and thank you, that’s was some good ideas. But the data is definitely connected and not clock. I experimented with different timings, etc. Maybe I should de-solder the screw terminals and try to solder the wires directly to the board? I guess why not try?..?

It does sound like the signal isn’t making it. For the screw terminal, make sure you have a good solder joint, and that it has made good contact with the gold ring. Another thing to check for is wire insulation inserted into the screw terminal can prevent good contact. Sometimes stripping a bit more of the insulation can help. If you have a multimeter, you can check connectivity from the screw terminal (or the 0.1" header) to the end of your connector. Of course you can always go direct and skip the screw terminal!

If you have another controller or LED strip (or a friend that does), troubleshooting is a lot easier by swapping things out to find out which is having the problem.

It’s possible that your Pixelblaze has a hardware problem, if thats the case I can get you a replacement.

It’s also possible the first LED on the strip went bad. That could happen from electrostatic discharge, or a manufacturing defect. If it did, sometimes trimming off the first LED can recover the rest of the strip.

I have just the same problem, funny thing is when I select APA102 on 1MHz i get all pixels lighting up, quite wildly in colors but at least it works, so I do know that the LEDs are fine.

I’d like to give tasmota a try but you firmware doesn’t seem to suport a reflashing. How are we supposed to get updates?

Hi @wiebel,
Thats odd, are you sure the data line and not the clock line is connected? What kind of LEDs do you have?

I don’t think that an update would help, but If you want to update Pixelblaze see this post:

Thanks for that quick reply. I actually have two Pixelblazes, one of which now sporting v2.21, thanks to you, both have the same issue, I have tried several LED stripes. Also I’d like to use the module via mqtt, sadly I failed to flash tasmota by the /update url, is there any easy way to flash it or do I need to get out a ttl uart?

Can you send a picture of the connections and the LEDs? What type are they?

Are you trying to overwrite Pixelblaze firmware? It won’t really be Pixelblaze after that, and you’ll be in unsupported territory. If you do want to go down that path, then yes you will need an esp8266 programmer (a uart and some buttons can make do).

Well I’m sorry to report but nothing comes my way. I had a neopixel ring that I hooked up but also only the first LED lit white. I tried other patterns but got nothing.

I cut and restripped a new section of wire. I also resoldered the scew terminal blocks.

I tested the connectivity with my multimeter from the terminals to the LED strip connection point. I also tested connectivity from the little VIN CLK DAT GND holes by the terminal to the LED strip. Connectivity was all good for all.

I tried changing the number of LED’s in the configuration settings and also experimented with the timing but had no results.

So all that wiring and connections seem good but does any of this make any sense? I have checked over and over that VIN DAT GND are wired correctly and also the LED strip and ring are connected properly.

Has anyone ever recovered from these kind of crazy problems before and if so how?

Hi @Xsonic,
It does sound like there’s a hardware issue. Can you send me an email with your info (name, Tindie order number if you have that handy) and I’ll get you a replacement.

This is happening to me as well. By admission I am a novice at soldering but pretty sure all connections are made properly and wiring is configured as intended for the 2m ws2812 strip which I also bought from electromage on tindie. No amount of tinkering in settings has yielded results other than the single led lighting up.
Going to revisit the scew terminal solder points and see if it needs fixing but I wanted to check here to see if I was missing something.

Hi @Breakfasteater,
Can you send photos of the board, wiring, and settings?

I see this thread is about 2 months old, but I just got mine hooked up today after receiving it a few days ago and same issue. I’ve gone through the settings as described in other troubleshooting threads but no luck. Currently I’m running it from the USB only, the only difference I see from this thread to my issue is when i power the strip (WS2812) from the usb only I get 1 bright LED, if I disconnect the power VIN from the board and connect external power (recommended 15A PS) and usb powering the board only I get a dimly lit LED. Last if I try to power the LEDs and the board off the PS (no USB) the board won’t power up and the voltage at the VIN/GND pins is ~2.2V. Seems like a short somewhere.

I’ve found with one of my LED matrices, when powered on only the first LED lights until my PixelBlaze has booted and started outputting. These matrices don’t seem to like running really fast. Mine are set to “Buffered (x2 rate) WS2812 / NeoPixel”, “333ns/667ns”. Have you tried all combinations?

There’s a setup guide here:

in case you’ve not found it already.

It might be easiest to focus on just one setup and try to get that working. With your 15A power supply (it’s 5V?), You have its DAT and 5v connected to the LED strip and the PixelBlaze and the PixelBlaze’s DAT ping connected to the LED strip’s DI (or DIN or similar)?

Maybe posting a picture of your setup would help.

It’s booted up all the way, I can load the page, I see it blink when I make changes.

It’s wired like the picture. It’s only 3 wires not much to screw up.

I’ve tried the settings you suggested and no difference. Just first LED lit, nothing on the rest.

Hmm… Silly question time… Are you confident that you’re feeding the DAT pin into the correct end of the strip?

Same end as the 5mm power input

Hi @justinmd,
That does sound like a power issue. 2.2V is much too low for PB to run.

If you have a 5V 15A supply connected and measure 2.2V and the LEDs are OFF, I would expect something is getting very very hot, or the power supply is bad. Depending on how many LEDs you have connected, if they are all illuminated it could cause that kind of voltage drop if it overwhelms the power supply, but thats not what it sounds like you are describing.

Since it boots on USB and isn’t frying your USB power supply or causing an overcurrent shutdown, I would guess that the power supply is bad and not a short in the strip.

In terms of data direction, the strips usually have small labels like “DI/DO” for data in, data out, or a directional arrow. Some have a label on the input side (look near the cut/join points between LEDs). Some strips have power on both ends. A photo would really help there.

I’d also check the soldering, and that if you use the screw terminal that the wire has enough insulation stripped. Forgive me if you’ve been over that all before, just tossing out possibilities!