Troubleshoot 12mm Diffused Thin Digital RGB LED Pixels (Strand of 25) - WS2801

Stone cold newbie. Purchased PB V3 bundle with 1m 140 count strand. Eventually got it to work though setting up the connection on my PC proved impossible and on my android phone was/is sketchy. Decided to branch out and switch to 12mm Diffused Thin Digital RGB LED Pixels (Strand of 25) - WS2801 from Adafruit for a specific project. I’m only workings with the 25-pixel strand right now. A few LEDs randomly turn on when power is applied, but then nothing happens. I’ll be damned if I can figure out what’s going on. I’ve checked the Adafruit Troubleshooter but since it refers to Arduino it may as well be written in Chinese. Question 1: Is this strand compatible with PB V3 [PB site says it should be but ???]. If it is what are my next steps. Thanks in advance.

Hey @alainpdx !

Just to check the basics, can you screenshot your Pixelblaze settings page so we can see how you have them config’d? Also want to just be sure to double check your wiring (check for clock and data being correct and not grounded…).

Problem 1 before I can even troubleshoot Pixels is I can’t get my PC to connect.

I can barely maintain a connection on my Android phone. I can’t connect to my network on my phone but can run in AP Mode. That’s made diagnostics hard. When I’m able to make a connection the 2 different strips [1m 140/m and 4m 60/m] I purchased from PB work…ish. I can access the basic pattern library but any of the other functions are impossible for me to perform on the tiny screen of my phone.

With respect to the 12mm LED Pixels. I purchase 2 strands, neither of which work as expected

I switched the CLK and DAT outputs from the PB so they’d matched the inputs shown in the Adafruit explainerimage

I really need to get PB running and stable on my PC in order to sort this out

Are you using a separate 5V power supply connected to the LEDs, or just using the 5V supplied by the USB through the PB to the LEDs? That strand of 25 LEDs will exceed the amount of current that a normal USB connection can supply, possibly resulting in a brownout condition for the PB.

If so, I would try disconnecting the LED string from the PB, and see if you can get a stable connection on your PC or phone.

1 Like

Thanks - you’ve definitely done things right as far as I can tell. I don’t see an obvious problem yet. I think you’ve passed many of the newb hurdles with your reply!

Though the WS2801 strand isn’t working for you, I think you’re saying you bought some strips from the Electromage store on Tindie, so they’re probably 5V SK9822 strips. Can you confirm if you got those to play patterns successfully? I hear you though that the connection from your phone via AP mode has been spotty, and client mode doesn’t seem to connect (even though found via the discovery service). This may be related to subnet isolation for 2.4GHz wifi clients vs 5GHz clients. See this thread for clues.

When you said you switched the DAT and CLK, are you saying those two lines were connected backwards for some time? I would be surprised if that damaged anything (though connecting PB’s DAT/CLK to the LED’s +5V could strain things I’m sure).

I thought I had some WS2801 sitting around to try to verify what you’re seeing, but I don’t; sorry.

Two final thoughts: Can we confirm you’re powering these well, and second, some ideas for how to update your firmware from 3.11 to 3.18.


You’ve probably read somewhere that the common rule of thumb is to plan for 60mA per pixel. The pixelblaze board itself usually consumes a little under 200mA. The micro USB connector on the board is rated for 1.8A, but not all USB type A ports can supply that much - if you’re powering the 25 WS2801 bullets off the micro USB, just be sure the source is rated high enough. For example, with something on my desk right now, one would be safe and the other quite questionable:


If you got the 240 LEDs on the 4m strip to work, hopefully you’ve already figured out a better power supply situation and are not using the micro USB for power at the same time as a 5V backfeed from the strip.


Given that I see from the Discovery Service that your board is on v3.11, it’d be a good idea to get you up to date with v3.18. This will be tricky since you haven’t been able to get client mode working well.

There were some stability improvements, especially in 3.16, that might help you. I’m going to suggest a procedure here which is a streamlined version of fixes from this thread.

  1. Free some space. First delete the following patterns via your phone (they’re all on the pattern library so you can re-upload them later):
    a. Scrolling Text Marquee 2D
    b. An Intro to Pixelblaze Code
    c. Midpoint Displacement 2D
    d. sound - spectro kalidastrip
    e. sound - blinkfade
    f. sound - spectromatrix 2D 3D

  2. On a device that can connect to your Pixelblaze in AP mode, first download this Signed Transfer Firmware Update file for the latest stable firmware, v3.18 while connected to the internet.

    Then, connect to PB’s AP, and navigate to (note: you cannot reach this URL on your firmware version if it’s in setup mode - you need to have successfully configured AP mode first to reach this page.)

    Upload the .stfu file for v3.18, and then pray to whichever silicon gods you worship.

Let us know how this goes!


[quote=“jeff, post:5, topic:1630”]
Can you confirm if you got those to play patterns successfully?
[/quote] - Yes both strips work fine, and can play patterns from my smartphone. They both worked fine powered from the micro USB. I also tried them on a 5V10Amp pod. I never use the USB and Pod at the same time, it’s either one or the other.
The PB output was wired exactly as the PB setup tutorial specified. I only switched the Clock and Data line when I was trying the 2801s because the Adafruit explainer showed the Input wires on 2801 were opposite of the PB Output pins. Regardless 2081 was not programable though all the LEDs lit when the wires were switched. I switched back when I went back to the strips.

I’ll work through the firmware upgrade tomorrow, that’s a little deeper dive

Not sure about the 2.4 vs 5GHz sitch. I read the thread but it doesn’t make sense to me.

@alainpdx ,
The first thing I noticed is on your discover page screen shot your PB hadn’t been seen for 385 minutes! My guess is that you had switched it over to AP mode. Once in AP mode the discovery service won’t see it anymore, and you won’t be able to access it from those links. The links will eventually time out and be cleared from the list, but they hang around for a while even if PB is offline.

Some WS2801 don’t like being driven at high speeds, so I would try 1MHz or lower for data speed and see if that helps things.

The longer I work on this the stupider I feel. It’s not supposed to be this hard…deeply deeply frustrating. Forget the 2801s I’ll just chalk that up to $80 worth of Adadumb. Right now I just want to access PB on my PC. I can access PB on my smartphone but everytime I try to access PB from my PC I keep landing on the WIFI setup page and can’t get past there. I’ve been trying to create an AP standalone network on my PC since there doesn’t seem like there’s anyway to maintain an internet connection and create a connection to the PB. The situtation is the same with my phone. Consequentially I have to toggle between network connections which makes accessing explainers and troubleshooting a nightmare. I’m willing to buy another PC or tablet or ??? just to run PB and make this work. I’m not completely illiterate when it comes to computers or electronics. I can follow instructions. All I want to do is to be able to access the PB libraries and run some lights without having to do a firewalk everytime. I’m confident PB is the way to go. I like what I’ve seen on the interweb. I like what I see when I can access it through my smartphone but there’s no way I’m editing or torubleshooting on my phone. What makes me nuts is I’m sure that working with someone IRL could probably sort this pretty quickly, but remotely :-(. The hackerspaces I’d normally check in Portland OR are still largely in Pandosleep or barely ticking over. Any hardware recommendations [tablets, controllers, ???] would be appreciated. I’ll spend what it takes to get this to work.

Hey Alain - sorry this is so frustrating. It’s almost certainly going to be fixed by some combination of ensuring you’re on the latest firmware, making sure your router and ESP32s wifi stacks get along, and making sure your computer and browser have relatively stock settings.

We’re you able to upload a 3.18 firmware? We should verify that before moving on to more expensive stuff.

From personal experience: MacBook with now Eero routers, and some Asus and D-link routers before have all worked well. However, I have screwed myself on connectivity many times, from hosts files to custom name servers, insufficient wifi signal strength, bad power, corrupted files on PB… all the above have been frustrating.

My router is new [Motorola MG7550 16x4 Cable Modem Plus AC1900 Dual Band WiFi Gigabit Router with Power Boost and DFS, 686 Mbps Maximum DOCSIS 3.0 - Approved by Comcast] and appears to be solid. I’ve no connectivity issues on any of my networked devices [PC, smartphone, ROKU, Kindle].

I’ve no idea how to update the firmware. I’ve followed your instructions but ¯_(ツ)_/¯. I downloaded [I think] " this Signed Transfer Firmware Update file for the latest stable firmware, v3.18 while connected to the internet" on my phone.

I think I’m in AP not Setup mode since I can access this screen

. That’s all the choices I’ve got … no menu option to “Upload the .stfu file for v3.18”. In either PB or browser. If I click on the download [again on my smartphone] I get “Can’t Open this file” so I don’t know if I’ve downloaded a link to the file or the actual file. This is why working on the phone has been so frustrating [not to mention I have to toggle between being connected to the internet or connected to PB]. If I take a screenshot on my phone to show what’s going on I have to log out of AP mode back into WIFI mode just to upload/download the image so I can access the image on my PC where I’m writing this, then back to AP mode on my phone. You get the idea …

Here’s a thought. If I buy another PB or ship the one I’ve got back to Electromage [or both] can I get one with the correct firmware installed or upgraded or is that part of the initial setup. Electromage is right across the river so my turnaround times won’t be too long. I realize you’re probably not the one to ask but does this sound like a reasonable alternative since there doesn’t seem to be any way for me directly access the board within the hardware, software limits I’ve got.

BTW I’ve also poked around the Adafruit site for help with the " 12mm Diffused Thin Digital RGB LED Pixels (Strand of 25) not working?" The kind of problems I experienced are not unheard of going as far back as 2012 but their solutions are for Arduino boards and also seem to be hit or miss. But that’s a separate battle to fight…

Great - from the phone you downloaded the firmware to, when connected to the Pixelblaze’s AP. can you reach the web address I gave above? The one ending in “/update”

I do agree - it’s a lot of juggling between devices connected to internet then not - seems to be pretty typical for small wifi IOT stuff. I just purchased something 6X the price of PB, also ESP based, and had to do the exact same stuff.

I think for most people, the original firmware (3.11) just auto updates successfully. I think you just have some unlucky combo of board/AP/computer situation. Dunno if newer routers are likely to be more or less lucky to be incompatible.

@wizard can speak to sending you an updated one - or maybe he has some other clever steps to try first.

Thanks again for your patience, much appreciated… really a blessing. If you were close I’d buy you a beer.

I could " reach the web address I gave above? The one ending in “/update” "

Hit update, still no love. When PB launches it’s still showing the old firmware.

I’ve got to give this a rest I’ve been trying to troubleshoot this as well as the 2801’s on a UNO board. Nothing but pain. Tomorrow is another day

Hey that’s progress. And just to confirm, were you able to delete all those patterns first to create some excess space? If not, that would cause this behavior.

Hi @alainpdx,
Sorry this is giving you a headache! I can swap out the PB, see if that helps!

Let me preface this with an expression of profound gratitude for the kindness and attention you’ve shown. It’s a rare thing. Despite my challenges, I wouldn’t hesitate to recommend PB because the true test of tech isn’t whether it’s problem-free but rather the community that grows around it. I feel blessed. I know I’m still at the start of this journey but I was able to turn over the ignition and get rolling.

For reasons known only to the Gods, I was finally able to update my firmware from my smartphone. Why it worked on the 50th try and not the 49th who the heck knows. I still can’t access it in Client Mode on my PC so I’m having to toggle between connections but I can live with that. I am able to access the program in AP Mode. To that end, I’m going to purchase a tablet solely for my LED projects. That should free up my PC and smartphone to maintain their connection to the web and assist with any further troubleshooting. I’m looking at the Samsung S7 Tab but if you have other recommendations I’d greatly appreciate them.

As far as the 2801’s I’m backtracking to my Arduino Uno to see if I have better luck working entirely within the Adafruit ecosystem. At this point, all I want is to make sure the 12mm Diffused Thin Digital RGB LED Pixels actually work. Once I’ve established they’re not damaged I’ll revisit running them on the PB. I bought two sets for a specific project that needed that form factor. Are you aware of any similar strips that might play better with the PB?

Thankyou, much appreciated but I think I sorted it out…sorta. Lets see how it goes for a few days. I really appreciate the support. Do you have any suggestions for RGB LED Pixels that are not 2801s that will play nice with PB. Thanks again.

1 Like

@alainpdx, @jeff is truly an amazing person and an asset to the community, and I’m glad he’s been able to help you out and get it updated.

For LEDs, there are WS2811 based string lights in the same form-factor as those WS2801s. They have a single data line instead of data + clock, and work at a fixed data speed (different LED type in settings). Otherwise they are very similar, and could be used for similar applications. They and might even be less expensive. I’ve seen them in both 5V and 12V versions.

I bought some of these about 3 years ago for my tree:

If you want, I could meet up with you somewhere and we can geek out over LEDs. I’ll bring some WS2811 and a spare PB, you can bring your PB & WS2801, and we can figure out what works.

I also have bought about a dozen of these WS2811 LED strings over the past few years, including a couple of them just a few months ago, that all worked perfectly with the PB.

1 Like

I didn’t want to leave anyone hanging after all the help I received. I was finally able to get the Pixels working and playing nice with the PB software. I had to model the whole setup in Arduino. One of the advantages of Arduino is you REALLY need to go step by step so I was able to figure out where I went wrong. PB is such a gift because most of this stuff is under the hood but it caused me to skip steps simply because I was unaware. My setup is still a little janky but at least I know it can work. Now I’m concentrating on creating a more robust build so everything continues to work if I move it. I’m taking a deep dive into the wonderful world of connectors, Wheee hoooo!

I wanted to add a short 2-sec video file to this post but it appears the forum doesn’t support them